GConf / ORBit calls bind() in content processes

RESOLVED FIXED in Firefox 57

Status

()

P3
normal
RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: jld, Assigned: jld)

Tracking

Trunk
mozilla57
Unspecified
Linux
Points:
---

Firefox Tracking Flags

(firefox57 fixed)

Details

(Whiteboard: sb+, crash signature)

Attachments

(1 attachment)

I'm seeing some Nightly crash reports where GConf/ORBit is trying to call bind().  I don't understand why it would be acting as a server when it's just trying to read a preference value (this seems to be, once again, nsProtocolProxyService), but maybe that's just how ORBit works.

Maybe it's time to just deal with nsProtocolProxyService and then make nsGConfService fail to start in content processes.

Updated

2 years ago
Whiteboard: sb+
See Also: → bug 1388576

Updated

2 years ago
Duplicate of this bug: 1388576

Updated

2 years ago
Priority: -- → P3
Comment hidden (mozreview-request)

Comment 3

a year ago
mozreview-review
Comment on attachment 8900952 [details]
Bug 1382442 - Don't try to use GConf in content processes.

https://reviewboard.mozilla.org/r/172404/#review177776

As the WebRTC proxy support is probably mostly used in corporate environments I would be surprised if disabling this feature will result in problems (I'm assuming that not many corporate users are using Linux).
Attachment #8900952 - Flags: review?(drno) → review+

Comment 4

a year ago
mozreview-review
Comment on attachment 8900952 [details]
Bug 1382442 - Don't try to use GConf in content processes.

https://reviewboard.mozilla.org/r/172404/#review179530
Attachment #8900952 - Flags: review?(gpascutto) → review+
Assignee: nobody → jld

Comment 5

a year ago
Pushed by jedavis@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7cec07add03a
Don't try to use GConf in content processes. r=drno,gcp
https://hg.mozilla.org/mozilla-central/rev/7cec07add03a
Status: NEW → RESOLVED
Last Resolved: a year ago
status-firefox57: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
You need to log in before you can comment on or make changes to this bug.