Closed Bug 138249 Opened 18 years ago Closed 17 years ago

Sanitizer needs option to allow images

Categories

(MailNews Core :: MIME, enhancement)

enhancement
Not set

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 193929
Future

People

(Reporter: panemec, Assigned: BenB)

References

Details

BuildID:    2002041803

Once bug 97055 is taken off the shelf, I envision the setup many people will
want for reading mail/news is:

Sanitize HTML (View Message as Simple HTML)
Allow images with blocking (honor the image acceptance policy per site)

This means having another option in the "View Message as" list: "Simple HTML
with images" (or something like that).

The image acceptance policy currently has a checkbox to "ask before downloading
an image".  This should be expanded to:
* ask before downloading an image in a web page
* ask before downloading an image in an email/news message
reassign to BenB
Assignee: ducarroz → ben.bucksch
This should be relatively easy to implement, as the backend already supports
this. Just allow the src attribute of <img>.

I think that this makes sense only after bug 28327. If that's implemented, we
might even be able to always allow images and rely on that pref to determine, if
they should be used.
Status: UNCONFIRMED → NEW
Depends on: ImgInMail
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Target Milestone: --- → Future
Very much related to bug 108153, sorry I forgot to mention that earlier.
Depends on: 108153
Yes, but that's fixed already.
No longer depends on: 108153
QA Contact: gayatri → trix
Gee, I didn't even realize I had a bug about this. Ere fixed this some time ago.

*** This bug has been marked as a duplicate of 193929 ***
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
verified dup
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.