Verify that histogram_tools.py breaks compilation if "bug_numbers" is missing from new histograms

RESOLVED FIXED in Firefox 56

Status

()

defect
P1
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Dexter, Assigned: Dexter)

Tracking

Trunk
mozilla56
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox54 unaffected, firefox55 wontfix, firefox56 fixed)

Details

(Whiteboard: [measurement:client])

Attachments

(1 attachment)

Assignee

Description

2 years ago
That did not seem to happen in bug 1356812, when a new histogram was added with no bug_numbers field.
Assignee

Updated

2 years ago
Assignee: nobody → alessio.placitelli
Priority: -- → P1
Whiteboard: [measurement:client]
Assignee

Updated

2 years ago
Blocks: 1356812
Assignee

Comment 1

2 years ago
Looks like that, even if the whitelist file is loaded, it is never used. This seems to be a regression from bug 1365577.
Blocks: 1365577
Assignee

Comment 2

2 years ago
Hey Chris, this patch marks the "whitelists" variable as global within |load_whitelists()|, otherwise the data won't be available from outside the function.

It also fixes the histogram that landed while this was broken.
Attachment #8888215 - Flags: review?(chutten)

Updated

2 years ago
Attachment #8888215 - Flags: review?(chutten) → review+

Comment 4

2 years ago
Pushed by alessio.placitelli@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/4ff87819abe8
Fix loading the whitelist file from histogram_tools.py. r=chutten
https://hg.mozilla.org/mozilla-central/rev/4ff87819abe8
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
You need to log in before you can comment on or make changes to this bug.