Closed Bug 1382582 Opened 4 years ago Closed 3 years ago

Fix 18 tests failures on devtools/client/inspector/boxmodel due the EventEmitter refactoring

Categories

(DevTools :: Inspector, enhancement, P3)

enhancement

Tracking

(firefox57 fix-optional)

RESOLVED DUPLICATE of bug 1382601
Firefox 56
Tracking Status
firefox57 --- fix-optional

People

(Reporter: zer0, Assigned: ystartsev)

References

Details

Failing tests:

devtools/client/inspector/boxmodel/test/browser_boxmodel.js
devtools/client/inspector/boxmodel/test/browser_boxmodel_computed-accordion-state.js
devtools/client/inspector/boxmodel/test/browser_boxmodel_editablemodel.js
devtools/client/inspector/boxmodel/test/browser_boxmodel_editablemodel_bluronclick.js
devtools/client/inspector/boxmodel/test/browser_boxmodel_editablemodel_border.js
devtools/client/inspector/boxmodel/test/browser_boxmodel_editablemodel_pseudo.js
devtools/client/inspector/boxmodel/test/browser_boxmodel_editablemodel_stylerules.js
devtools/client/inspector/boxmodel/test/browser_boxmodel_guides.js
devtools/client/inspector/boxmodel/test/browser_boxmodel_layout-accordion-state.js
devtools/client/inspector/boxmodel/test/browser_boxmodel_navigation.js
devtools/client/inspector/boxmodel/test/browser_boxmodel_offsetparent.js
devtools/client/inspector/boxmodel/test/browser_boxmodel_positions.js
devtools/client/inspector/boxmodel/test/browser_boxmodel_properties.js
devtools/client/inspector/boxmodel/test/browser_boxmodel_pseudo-element.js
devtools/client/inspector/boxmodel/test/browser_boxmodel_rotate-labels-on-sides.js
devtools/client/inspector/boxmodel/test/browser_boxmodel_sync.js
devtools/client/inspector/boxmodel/test/browser_boxmodel_update-after-navigation.js
devtools/client/inspector/boxmodel/test/browser_boxmodel_update-after-reload.js


The refactoring is currently only on:

https://github.com/zer0/gecko/tree/event-emitter-1381542

We need to address the test failures before land this patch in m-c.
Here the original try build with the failures:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=bba13e27a2371fa8aad68b9b227534b31829cb0d

Those failures are most likely due the breaking change in how the `EventEmitter` emits event.

Previously, the first argument was the event type:

  myEmitter.on("custom-event", (eventType, message) => { ... });

Now the first argument is the message:

  myEmitter.on("custom-event", (message) => { ... });

In the majority of the scenario the `eventType` is ignored by our code, so we should just remove it from the function's signature.

For more details and edge cases, see: https://github.com/devtools-html/snippets-for-removing-the-sdk/#events
Flags: qe-verify-
Priority: -- → P2
Assignee: nobody → zer0
Status: NEW → ASSIGNED
Priority: P2 → P1
Target Milestone: --- → Firefox 56
No longer blocks: 1381542
Blocks: 1384546
Whiteboard: [nosdk]
This is an assigned P1 bug without activity in two weeks. 

If you intend to continue working on this bug for the current release/iteration/sprint, remove the 'stale-bug' keyword.

Otherwise we'll reset the priority of the bug back to '--' on Monday, August 28th.
Keywords: stale-bug
Assignee: zer0 → nobody
Status: ASSIGNED → NEW
Priority: P1 → --
Keywords: stale-bug
Priority: -- → P3
Component: Developer Tools → Developer Tools: Inspector
Assignee: nobody → ystartsev
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1382601
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.