Active area for some checkboxes has changed since Preferences re-org

VERIFIED FIXED in Firefox 56

Status

()

defect
P1
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: bogdan_maris, Assigned: evanxd)

Tracking

({regression})

Trunk
Firefox 56
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify +

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox54 unaffected, firefox55 unaffected, firefox56 fixed, firefox57 verified)

Details

(Whiteboard: [photon-preference])

Attachments

(1 attachment)

[Affected versions]:
- Firefox 56.0a1

[Affected platforms]:
- Ubuntu 16.04 32bit
- macOS 10.12.5
- Windows 7 64bit

[Steps to reproduce]:
1. Start Nightly
2. Visit about:preferences#search 
3. Click the blank area from the right of 'Provide search suggestion' or 'Show search suggestions in address bar results'
4. Visit about:preferences#privacy
5. Click the blank area from the right of 'Enable Profile Autofill'

[Expected result]:
- Action is recorded in the checkbox for each setting mentioned above.

[Actual result]:
- Nothing happens.

[Regression range]:
- This is a recent regression for the options from about:preferences#search

Last good revision: af7b2525a93468f6eb6480cb13b2fd3b58b17579
First bad revision: 0e007009a6be3a2ce7954d39ee0589a61e2ef180
Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=af7b2525a93468f6eb6480cb13b2fd3b58b17579&tochange=0e007009a6be3a2ce7954d39ee0589a61e2ef180

Culprit: Evan Tseng — Bug 1365133 - Reorganize Preferences sections and regroup <xul:groupbox> elements by new categories - Part 1. r=jaws

For 'Enable Profile Autofill' I could not determine a regression since the option was enabled and disabled on different consecutive builds. I assume it was the same since forever.
Flags: needinfo?(evan)
Forgot to mention that the options from Sync Settings (after logging into Firefox Account) have the same issue. Those did not have this feature after bug 1330121 though.
(Assignee)

Updated

2 years ago
Assignee: nobody → evan
Status: NEW → ASSIGNED
Flags: needinfo?(evan) → qe-verify+
Priority: -- → P1
Whiteboard: [photon-preference][triage]
Target Milestone: --- → Firefox 56
(Assignee)

Updated

2 years ago
Depends on: 1382954
(Assignee)

Comment 3

2 years ago
Hi Bogdan,

Thank you for filing the bug. I've patched to fix it.

For "Enable Profile Autofill" checkbox, we cannot fix here because it is inserted by a system add-on (autofill). We will fix it at Bug 1382954. Additionally, we already have the issue for Firefox Account checkboxes in current nightly. For sure, let's fix it here.
Comment hidden (mozreview-request)
(Assignee)

Updated

2 years ago
Attachment #8888679 - Flags: review?(jaws)
(Assignee)

Comment 5

2 years ago
Hi Jared,

Could you help review the patch?

Thank you.
Whiteboard: [photon-preference][triage] → [photon-preference]

Comment 6

2 years ago
mozreview-review
Comment on attachment 8888679 [details]
Bug 1382660 - Allow all <checkbox> in preferences to expand to full width.

https://reviewboard.mozilla.org/r/159714/#review165928
Attachment #8888679 - Flags: review?(jaws) → review+
Comment hidden (mozreview-request)
(Assignee)

Comment 8

2 years ago
Rebased the patch. Let's land it once the try[1] is good.

[1]: https://treeherder.mozilla.org/#/jobs?repo=try&revision=8614d0b168f0
(Assignee)

Comment 9

2 years ago
Looks the try is good. Let's land it.
Keywords: checkin-needed

Comment 10

2 years ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/e2e5780e0cb4
Allow all <checkbox> in preferences to expand to full width. r=jaws
Keywords: checkin-needed

Comment 11

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/e2e5780e0cb4
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED

Comment 12

2 years ago
Him,
I tried to verify this bug on Nightly 57 but I couldn't find "Enable Profile Autofill" checkbox.
Is there another name for this checkbox or the checkbox doesn't exist anymore?
Flags: needinfo?(bogdan.maris)
(In reply to Hani Yacoub from comment #12)
> Him,
> I tried to verify this bug on Nightly 57 but I couldn't find "Enable Profile
> Autofill" checkbox.
> Is there another name for this checkbox or the checkbox doesn't exist
> anymore?

'Enable Profile Autofill' has actually changed to 'Autofill addresses' in Fx 57 by the looks of it.
Flags: needinfo?(bogdan.maris)

Comment 14

2 years ago
Build ID: 20170808114032
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

Verified as fixed on Firefox Nightly 57.0a1 on Windows 10 x 64, Mac OS X 10.12 and Ubuntu 16.04 x64.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.