[Activity Stream] Top sites titles are displayed with the title's last characters

VERIFIED FIXED in Firefox 56

Status

()

VERIFIED FIXED
a year ago
a year ago

People

(Reporter: itiel_yn8, Assigned: Mardak)

Tracking

unspecified
Firefox 56
Points:
---

Firefox Tracking Flags

(firefox56? fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8888440 [details]
Screenshot

Environment:
Windows 10
Nightly 56.0a1 2017-07-20 running as RTL (you can use the Force-RTL addon to reproduce)

STR:
1. On a clean profile, enter a site whose title is LTR (and preferably one that relatively has lots of characters), for example:
https://wiki.mozilla.org/Features/Release_Tracking
2. Open a new tab, observe the newly added item added to the top sites.

ER:
The first characters of the page's title should appear on that tile.

AR:
The last characters are shown, in my machine it would be "MozillaWiki" instead of "Features/Release" or something like that.

See screenshot.

The same issue can be reproduced if running Nightly as LTR, and entering a site whose title is in RTL.
See bug 1324890 that is very similar to this one, it was fixed by 1357656.

The problem with fixing this issue is that the ellipsis character would appear really close to the thumbtack icon.
A possible solution would be to use fade-out like it's already done in the tab bar.

Comment 1

a year ago
It would really nice to fix this issue, since this makes the new tab page pretty unusable for RTL users.

The correct fix is probably to wrap these titles in a <span dir=auto></span>.

Comment 2

a year ago
[Tracking Requested - why for this release]:
This should probably be considered a blocking issue for the release of Firefox that ships activity streams for the first time.  it'd be nice to avoid having to ship a dot release similar to what we had to do for bug 1357656.
status-firefox56: --- → affected
status-firefox57: --- → affected
tracking-firefox56: --- → ?
tracking-firefox57: --- → ?
(Assignee)

Comment 3

a year ago
Fixed with https://github.com/mozilla/activity-stream/pull/2952 to be uplifted via bug 1383917.
Blocks: 1383917
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Assignee: nobody → edilee
status-firefox56: affected → fixed
tracking-firefox57: ? → ---
Target Milestone: --- → Firefox 56
(Reporter)

Comment 4

a year ago
Fixed on latest Nightly.
Status: RESOLVED → VERIFIED
status-firefox57: affected → ---
You need to log in before you can comment on or make changes to this bug.