Closed Bug 1382867 Opened 2 years ago Closed 2 years ago

Layout problem with writing-mode and flexbox

Categories

(Core :: Layout, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1267462
Tracking Status
firefox57 --- wontfix
firefox58 --- affected

People

(Reporter: eric, Unassigned)

Details

(Keywords: testcase)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:56.0) Gecko/20100101 Firefox/56.0
Build ID: 20170719100145

Steps to reproduce:

I created a minimal testcase showing the problem, located at http://meyerweb.com/eric/css/tests/firefox/writing-mode-flexbox.html.


Actual results:

When using vertical writing modes on elements in a flex container one or both of the vertically-written elements are badly misplaced.  The exact nature of the misplacement depends on the value of `justify-content`.  (See above testcase for more details.)


Expected results:

The headings in the testcase should be visible and placed within the flex container.
Component: Untriaged → Layout
Product: Firefox → Core
Priority: -- → P3
Might be a dupe of bug 1282940.  (Related underlying problem, at least.)

In any case, part of the family of bug 1079155 --> marking as blocking that bug.  Also, wontfix for 57 (current beta) since this isn't a recent regression and its patch would likely have nonzero risk for uplift.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase
Version: 56 Branch → Trunk
I believe this is fixed in Nightly (version 60) likely by bug 1267462 (which fixed a lot of similar issues with flexbox + vertical writing-modes causing absurdly large/offscreen content).

I tried the steps in comment 0 and everything seems normal now -- the h1/h2 elements are both onscreen now and are both positioned at the left (or with manual justify-content tweaks in devtools: at the right or center, as you'd expect).

--> Duping to bug 1267462.  This should be fixed in Firefox 60, which hits the Firefox Beta release-channel sometime next week.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1267462
You need to log in before you can comment on or make changes to this bug.