Closed Bug 1382884 Opened 4 years ago Closed 4 years ago

With media.autoplay.enabled=false, YouTube player starts in playing state (but not playing)

Categories

(Core :: Audio/Video: Playback, defect, P3)

x86_64
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1412772

People

(Reporter: botond, Unassigned)

References

Details

STR:

  1. Set media.autoplay.enabled to false
  2. Load any youtube video

Expected results:

  The video is not playing, and it's in the stopped/paused
  state, such that the button in the player's bottom left
  corner is the "Play" button, and a single click on it
  will start the video.

Actual results:

  The video is not playing, but the player is somehow still
  in the "playing" state, such that the button in the bottom
  left corner is "pause". Pressing that button once does not
  play the video, it changes the button image to be "play".
  A second press is required to actually start the video.
Could you try with this build?
https://treeherder.mozilla.org/#/jobs?repo=try&revision=f1933e0291161e43e0ffcac8a4cabfc7be0e7b6f

And see if it makes any difference?

Thanks.
Flags: needinfo?(botond)
The behaviour is the same with that build.
Flags: needinfo?(botond)
Component: Audio/Video → Audio/Video: Playback
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1412772
You need to log in before you can comment on or make changes to this bug.