Closed Bug 1382902 Opened 3 years ago Closed 3 years ago

stylo: thread '<unnamed>' panicked at 'Resolving style on element without current styles'

Categories

(Core :: CSS Parsing and Computation, defect, P1)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1383001

People

(Reporter: hiro, Unassigned)

References

(Blocks 3 open bugs)

Details

(Keywords: assertion, testcase)

Attachments

(1 file)

Attached file Jesse's test case
From bug 1381357 comment 2.

This is different from 1381357, I believe bug 1381357 has been already fixed.
Attaching test cases (made by Jesse) hits a debug_assert! in Servo_ResolveStyle() because there remains an animation restyle hint when we call Servo_ResolveStyle().  That's because the animation is not yet in EffectSet at the moment, so we fail to process a SequentialTask and have no chance to process animation-only restyle.  I think this behavior is harmless since the missed animation-only restyle will be processed in the next tick.

That's said, we should fix the debug_assert anyway.

Thank you Jesse for the test case, your test case is very simple as usual and easy to understand what's going on.
Flags: in-testsuite?
Keywords: assertion, testcase
Version: unspecified → Trunk
No longer blocks: stylo-release
Priority: -- → P1
The test case does no longer cause the panic. I guess Emilio fixed it in bug 1383001. I will confirm it later.
Flags: needinfo?(hikezoe)
Confirmed.
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(hikezoe)
Resolution: --- → DUPLICATE
Duplicate of bug: 1383001
You need to log in before you can comment on or make changes to this bug.