Stylo: Crash in alloc::oom::default_oom_handler | style::context::ElementCascadeInputs::new_from_element_data

RESOLVED DUPLICATE of bug 1383001

Status

()

--
critical
RESOLVED DUPLICATE of bug 1383001
a year ago
a year ago

People

(Reporter: jseward, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

a year ago
This bug was filed from the Socorro interface and is 
report bp-450a7dea-7289-46df-ba98-a67600170721.
=============================================================

This is topcrash #17 in the Windows nightly of 20170720030203.
Looks like Stylo is OOMing.
(Reporter)

Updated

a year ago
Flags: needinfo?(bobbyholley)
Summary: Crash in alloc::oom::default_oom_handler | style::context::ElementCascadeInputs::new_from_element_data → Stylo: Crash in alloc::oom::default_oom_handler | style::context::ElementCascadeInputs::new_from_element_data
This looks like it could be a duplicate of bug 1383001. Can anyone confirm if this the case?
(In reply to Julian Seward [:jseward] from comment #0)
> Looks like Stylo is OOMing.

The Rust equivalent of MOZ_CRASH just shows up as default_oom_handler for whatever reason. Note that the crash report you linked has MOZ_CRASH Reason of "called `Option::unwrap()` on a `None` value".
(In reply to Ryan Jones [:sciguyryan] from comment #1)
> This looks like it could be a duplicate of bug 1383001. Can anyone confirm
> if this the case?

Yeah, that sounds right. I recall reading that the crash signature show up differently sometimes.
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(bobbyholley)
Resolution: --- → DUPLICATE
Duplicate of bug: 1383001
You need to log in before you can comment on or make changes to this bug.