Closed Bug 1383065 Opened 2 years ago Closed 2 years ago

[Form Autofill] Trigger autofill broken on 3 fields forms

Categories

(Toolkit :: Form Manager, defect, major)

56 Branch
defect
Not set
major

Tracking

()

RESOLVED FIXED
mozilla56
Tracking Status
firefox-esr52 --- unaffected
firefox54 --- disabled
firefox55 --- disabled
firefox56 --- fixed

People

(Reporter: adrian_sv, Assigned: selee)

References

Details

(Keywords: regression, Whiteboard: [form autofill:M4])

Attachments

(2 files)

[Description:]
As far as I can tell at this moment, autofill doesn't work on 3 fields forms. This is a regression, altough we couldn't bisect better than:
--good 2017-07-19
--bad  2017-07-20

[Steps:]
1. Open FF, have two profiles.
2. Open attached html, or any html that contains a form with 3 autocomplete fields.
3. Double click on each of the 3 fields.

[Actual Result:]
Autofill is triggered.

[Expected Result:]
Autofill isn't triggered.


Note:
Setting this bug severity to blocker for the time being, since atm it doubles the QA effort needed - we are currently running pre-beta full tests) - and we cover the tests on both 07.19 build and 07.21 build; from what I can tell, the autofill breakage is only affecting 3 fields forms - but IMO, we'd be on the safe side tracking this as a high severity issue until somebody can confirm it's a trivial change that caused it.(my assumption)
Assignee: nobody → selee
Status: NEW → ASSIGNED
Whiteboard: [form autofill] → [form autofill:M4]
Comment on attachment 8889341 [details]
Bug 1383065 - Consider the form with 3 address fields as a valid address form.

https://reviewboard.mozilla.org/r/160422/#review165654

Thanks.
Attachment #8889341 - Flags: review?(lchang) → review+
Pushed by lchang@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/22d7b65df134
Consider the form with 3 address fields as a valid address form. r=lchang
https://hg.mozilla.org/mozilla-central/rev/22d7b65df134
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
Depends on: 1384185
You need to log in before you can comment on or make changes to this bug.