Status

()

RESOLVED DUPLICATE of bug 1097619
a year ago
a year ago

People

(Reporter: lcm, Unassigned)

Tracking

54 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Android 7.1.2; Mobile; rv:54.0) Gecko/54.0 Firefox/54.0
Build ID: 20170628221524

Steps to reproduce:

When one clears the download history, Firefox also deletes the corresponding files.



Expected results:

This behavior makes no sense:
1) Firefox on Desktops comes with a clear action, too. However, both are inconsistent with another.
2) If the behavior in FFx for Android is intended, it must not be label with "Clear Downloads". "Delete downloads" is more suitable.
3) And finally, from the UX POV: You should ALWAYS ask for confirmation for actions that delete files. The selected action might be unintended but the resulting loss of data of big damage for the user.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1097619
You need to log in before you can comment on or make changes to this bug.