OBJECT tag broken in moz1.0

VERIFIED DUPLICATE of bug 108557

Status

()

Core
DOM: Core & HTML
VERIFIED DUPLICATE of bug 108557
16 years ago
7 years ago

People

(Reporter: Sorin Lazareanu, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
The OBJECT tag does not load the Java plug-in in 1.0 RC1. The APPLET tag works 
correctly - with JDK 1.4.0. 
The resource at http://sorin.nondimensional.org uses the OBJECT tag - used to
work in 0.9.9.
The resource at http://sorin.nondimensional.org is the same as the previous one 
with the OBJECT tag replaces by the APPLET tag.

I installed RC1 after I uninstalled 0.9.9. 
My "plugin" directory contains:
NPJava11.dll
NPJava12.dll
NPJava13.dll
NPJPI140.dll
NPOJI610.dll

Have I missed something when I installed RC1?

Comment 1

16 years ago
Not even the older 1.3.x JREs are working, it seems the code that uses the Java
Object Tag (in IE style) has been disabled in RC1. This is a HUGE disapointment
and leaves RC1 unusable for me. I'll go back to 0.9.9...

PS: I'm on Redhat 7.1.

Comment 2

16 years ago
There has been some discussion that this bug might be a dupe of Bug #46569, but
it does not seem to be (how could it be if the problem did not exist in ver
0.9.9?).  Can someone mark this bug confirmed?  I have confirmed that it exists
on build 2002042608 running Win98.

Comment 3

16 years ago
http://bugzilla.mozilla.org/show_bug.cgi?id=108557

Comment 4

16 years ago
<OBJECT classid="clsid:blah-blah-blah"> is windows-only stuff. You need <embed>
tag  inside of <object> to make it cross-platform.
See http://java.sun.com/j2se/1.4/docs/guide/plugin/developer_guide/using_tags.html

Note that this change (bug 108557) was initiated bug Sun Java Plugin people.
You can argue with them if you feel that this behavior is bad
Assignee: idk → joe.chou
Component: Java-Implemented Plugins → OJI
QA Contact: avm → pmac
(Reporter)

Comment 5

16 years ago
After some detective work I found the combination that seems to work with the 
OBJECT tag in Mozilla 1.0 RC1. I didn't find something to document it. 

Here is the link: http://sorin.nondimensional.org/javaTags4.html

The bottom line is: there is no tag that is "Strict HTML 4.01" compliant and 
works in both Mozilla and IE.
(Reporter)

Updated

16 years ago
(Reporter)

Updated

16 years ago
(Reporter)

Comment 6

16 years ago
Mozilla 1.0 doesn't have this issue fixed either.  By the way <embed> (and 
<applet> too) is not a "HTML 4.01 Strict" element and in the Sun's site there 
is no mention of any other classid schema beside "clsid:...": 

http://java.sun.com/products/plugin/versions.html

on the contrary, the Sun site mention that "In theory Netscape 6 should work 
the same as IE.*"

The sad part is that the compliant OBJECT tag used to work in 0.9.9 and nobody 
cares to verify what happened since then.  Mozilla makes claims to "support 
more web standards, more deeply" but in this case the claim doesn't seem to 
hold true.  The bug remains unconfirmed for almost 2 month now. 

I have done some research to compare the implementation of tags supporting Java 
applets.  Here is the page:

http://sorin.nondimensional.org/javaTags.html

I wonder if there is any explanation for this situation...
*** Bug 156506 has been marked as a duplicate of this bug. ***

Comment 8

16 years ago
WFM in moz099 with JRE 1.3.1 and 1.4.1, but not working in moz1.0 rc1 or later
with either JRE 1.3.1 or 1.4.1. So there seems to be a regression between moz099
and moz1.00rc1. In the case of failing, the applet in Object tag seemed not
being recognized and not loaded at all.

Comment 9

16 years ago
Correcting Summary to ""OBJECT tag broken in moz1.0" and platform to all. The
fix of 80802 seemed to be  working till moz099, but broken since moz1.0 rc1.
Re-assign to jst, who fixed 80802,  for further investigation.
Assignee: joe.chou → jst
Component: OJI → DOM Content Models
OS: Windows 2000 → All
Hardware: PC → All
Summary: OBJECT tag not working with Java 1.4 plug-in → OBJECT tag broken in moz1.0
This is basically bug 153288; see also discussion in bug 108557.  I think
someone at Sun is very confused, but....

*** This bug has been marked as a duplicate of 153288 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 11

16 years ago
Actually this bug should be a duplicate of 108557, and see the new test case of
how Object tag should work now at the end of the comments in 108557.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 12

16 years ago
Marked as duplicate of 108557.

*** This bug has been marked as a duplicate of 108557 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE

Comment 13

16 years ago
To make the long story short, basically, at first, 80802 implemented support for
Object tag in mozilla; then in 108337 the classid field in Object tag (part of
the implementation in 80802) was removed, which deprecated the Object tags using
classid field.

To make Object tag work now, try something like:

<object type="application/x-java-applet" code=Helloworld.class WIDTH= 50% HEIGHT
= 100> </object>

No need to specify classed, java version, etc. WFM on WindowsXP and Unix, with
moz1.0, netscape7.0pr1 and JRE 1.4.0_01 and 1.4.1.
(Reporter)

Comment 14

16 years ago
Thank you for the clarification, I tested the tag and it works in Mozilla 1.0.
The following tag configuration works in Mozilla 1.0, IE6, Opera 6.03 and 
is "HTML 4.01 Strict" compliant:
<object
  type="application/x-java-applet"
  classid="clsid:CAFEEFAC-0014-0000-0000-ABCDEFFEDCBA"
  width="300" 
  height="400" 
  codebase="http://java.sun.com/products/plugin/autodl/jinstall-1_4_0-
win.cab#Version=1,4,0,0">
              <param name="code" value="HelloWorld.class">
              <param name="codebase" value="/Java/MyProject/classes">
              <param name="type" value="application/x-java-applet;jpi-
version=1.4">
            </object>

Is anything here redundant?
      
(Reporter)

Comment 15

16 years ago
Sorry, the tag with classid doesn't work in Mozilla. It seems that there is 
not "HTML 4.01 Strict" compliant tag that works in both Mozilla and IE.

Comment 16

16 years ago
*** Bug 157612 has been marked as a duplicate of this bug. ***

Comment 17

16 years ago
verified dup
Status: RESOLVED → VERIFIED

Updated

7 years ago
Assignee: jst → nobody
Component: DOM: Abstract Schemas → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.