4.12 - 11.5% Explicit Memory / Images / JS / Resident Memory (linux64, osx-10-10) regression on push f4378a5e6c7f (Thu Jul 20 2017)

RESOLVED DUPLICATE of bug 1382768

Status

()

Core
DOM
RESOLVED DUPLICATE of bug 1382768
11 months ago
11 months ago

People

(Reporter: jmaher, Unassigned)

Tracking

({perf, regression})

53 Branch
perf, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 months ago
We have detected an awsy regression from push:

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?changeset=f4378a5e6c7f	

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

 12%  Images summary linux64 opt      7,139,271.02 -> 7,960,596.03
  9%  JS summary linux64 opt          121,348,088.57 -> 131,855,877.17
  8%  JS summary osx-10-10 opt        127,459,719.45 -> 137,044,126.04
  7%  Explicit Memory summary linux64 opt 341,425,146.09 -> 365,357,446.73
  7%  Explicit Memory summary osx-10-10 opt 373,190,737.59 -> 398,597,454.89
  4%  Resident Memory summary linux64 opt 498,164,668.06 -> 518,687,975.77


You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=8143

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://developer.mozilla.org/en-US/docs/Mozilla/Performance/AWSY
(Reporter)

Comment 1

11 months ago
:baku, I see you authored the patch which caused this memory regression, could you take a look at this and help determine if we can reduce/fix this regression or if we need to accept this.
Component: Untriaged → DOM
Flags: needinfo?(amarchesini)
Product: Firefox → Core

Updated

11 months ago
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Flags: needinfo?(amarchesini)
Resolution: --- → DUPLICATE
Duplicate of bug: 1382768
You need to log in before you can comment on or make changes to this bug.