Closed Bug 1383319 Opened 2 years ago Closed 2 years ago

stylo: has_current_style debug assertion on test-case with animation and innerHTML.

Categories

(Core :: CSS Parsing and Computation, defect, P2)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1383001

People

(Reporter: emilio, Unassigned)

References

Details

(Keywords: assertion)

Attachments

(1 file)

Seen while investigating bug 1383001.
Attached file testcase
display: contents is just to disable lazy frame construction.
(contenteditable also works, and would be nicer for a reftest, since ideally we'd make the display: contents stuff work with lazy frame construction).
Hiro, I think this is because we restyle, then do a frame constructor pass with the outdated styles... Then update animations.

Is that right? If so, what's the course of action here? Tweaking the assertion would work, I guess...
Flags: needinfo?(hikezoe)
(In reply to Emilio Cobos Álvarez [:emilio] from comment #3)
> Hiro, I think this is because we restyle, then do a frame constructor pass
> with the outdated styles... Then update animations.
> 
> Is that right? If so, what's the course of action here? Tweaking the
> assertion would work, I guess...

Yeah, I am also thinking tweaking the assertion is a way we can do here. Let me think about the effective assertion.
Keywords: assertion
Priority: -- → P1
Priority: P1 → --
(P2 since it's a debug assertion which seems to be incorrect. Should be fixed but no rush)
Priority: -- → P2
I fixed this in bug 1383001.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1383001
Thanks again and again. :)
Flags: needinfo?(hikezoe)
You need to log in before you can comment on or make changes to this bug.