Screenshots button not visible when extensions.screenshots.system-disabled set to false

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
a month ago
a month ago

People

(Reporter: ithompson4, Unassigned)

Tracking

55 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a month ago
Created attachment 8889041 [details]
Screenshots button_is_invisble_initially_after_extensions.screenshots.system-disabled_set _to_false.png

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170720101430

Steps to reproduce:

1.Open Firefox with a clean profile
2.Navigate to about:config page
3.Click the "I accept the risk!" button
4.Search for the "extensions.screenshots.system-disabled" pref, set it to "false" 
5.Set the "extensions.screenshots.system-disabled" pref to "true"
6.Set again the "extensions.screenshots.system-disabled" pref to "false"


Actual results:

1, Toolbar extends to the right when  "extensions.screenshots.system-disabled" pref to "true", and contracts to the left when the "extensions.screenshots.system-disabled" pref to "false" but the screenshots button does not display (please see attached screenshot)
2. To make the button visible you have to move you mouse over the empty space displayed on the toolbar when "extensions.screenshots.system-disabled" pref is set to "false".


Expected results:

Screenshot button should have been displayed when "extensions.screenshots.system-disabled" pref, set it to "false" and dissappeared when  "extensions.screenshots.system-disabled" pref to "true".
(Reporter)

Comment 1

a month ago
When you move your mouse over the empty space displayed on the toolbar when "extensions.screenshots.system-disabled" pref is set to "false", one has to click on the icon outline displayed to make the icon fully display and become active.
(Reporter)

Comment 2

a month ago
Bug discovered during Firefox Developer Edition 55 Beta 11 Testday - Friday, July 21st, 2017
Please report your issue to https://github.com/mozilla-services/screenshots/issues
Status: NEW → RESOLVED
Last Resolved: a month ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.