Modal dialogs do not work in FF54/Linux/e10s/Responsive design mode

RESOLVED DUPLICATE of bug 1273997

Status

()

Firefox
Developer Tools: Responsive Design Mode
RESOLVED DUPLICATE of bug 1273997
5 months ago
4 months ago

People

(Reporter: inkatadoc, Unassigned)

Tracking

54 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 months ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:54.0) Gecko/20100101 Firefox/54.0
Build ID: 20170612122310

Steps to reproduce:

IF FF has e10s ENABLED:
1. Go to any page
2. Switch responsive view (Shift-CTRL-M)
3. open console (F12)
4. type "confirm('aaa')"



Actual results:

5. Returns false immediately, no modal shown

confirm(), alert() and prompt() exhibit the same behaviour



Expected results:

6. Open a modal confirm window

--- ADDITIONAL INFO ----

-------- This does NOT happen in:
* FF54/Linux/20170612122310 with e10S DISABLED (modals do work fine)
* FF54/Linux/20170612122310 outside responsive view (modals do work fine)

Updated

5 months ago
Component: Untriaged → Developer Tools: Responsive Design Mode
(Reporter)

Comment 1

4 months ago
Has anyone been able to reproduce this bug?
Thanks for filing!  This is currently a known issue with the new version of RDM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1273997
(Reporter)

Comment 3

4 months ago
Thank you! :-)
You need to log in before you can comment on or make changes to this bug.