Closed Bug 1383489 Opened 3 years ago Closed 3 years ago

Shutdown crash with crash reporter when open new tab If you have opened a problematic page in the past

Categories

(WebExtensions :: General, defect)

56 Branch
x86_64
Windows 10
defect
Not set

Tracking

(firefox-esr52 unaffected, firefox54 unaffected, firefox55 unaffected, firefox56 fixed)

RESOLVED FIXED
mozilla56
Tracking Status
firefox-esr52 --- unaffected
firefox54 --- unaffected
firefox55 --- unaffected
firefox56 --- fixed

People

(Reporter: alice0775, Assigned: kmag)

References

(Depends on 1 open bug, )

Details

(Keywords: crash, regression, reproducible, Whiteboard: [DUPEME])

Crash Data

Please provide your crash report ID: https://support.mozilla.org/kb/mozillacrashreporter
Component: Untriaged → Tabbed Browser
It seems to happen when the browser has hung up in the past.
And once you encounter this shutdown crash, it will be reproducible every time.

Exact STR is as follows.

Steps To Reproduce:
[prepare]
prepare-1. Make sure, only the about:home tab is opened at the first startup
prepare-2. Open https://bugzilla.mozilla.org/attachment.cgi?id=8889101
           --- browser will hang up due to Bug 1383478
prepare-3. Kill Nightly process

1. Start Nightly
2. Open any link(such as about:newtab) in new tab
3. Exit browser

Actual Results:
Nightly process remains for long period.
And finally, crash reporter dialog pops up.
bp-37f5111f-e1ac-492a-9d29-eb75a0170723

Expected Results:
Nightly process should disappear immediately.
Exit normally without crash.
Crash Signature: Crash in AsyncShutdownTimeout | profile-change-teardown | Extension Shutdown: screenshots@mozilla.org (Firefox Screenshots)
Keywords: crash, reproducible
Depends on: 1380267
Crash Signature: Crash in AsyncShutdownTimeout | profile-change-teardown | Extension Shutdown: screenshots@mozilla.org (Firefox Screenshots) → [@ AsyncShutdownTimeout | profile-change-teardown | Extension Shutdown: screenshots@mozilla.org (Firefox Screenshots) ]
[Tracking Requested - why for this release]:

Regression window:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=876f6d3d160852f68d6da1ad7353d8934bf27e84&tochange=23c63ef286cc35e1e31aa6a9afcaf00d227bf9d6

Regressed by: 23c63ef286cc	Kris Maglione — Bug 1357486: Follow-up: Wait for extension shutdown before starting storage shutdown. r=rhelmer
Blocks: 1357486
Component: Tabbed Browser → WebExtensions: General
Keywords: regression
Product: Firefox → Toolkit
Keywords: multiprocess
Summary: Shutdown crash when open new tab → Shutdown crash with crash reporter when open new tab
Summary: Shutdown crash with crash reporter when open new tab → Shutdown crash with crash reporter when open new tab If you have opened a problematic page in the past
I notice that huge memory and CPU usage before the crash reporter pops up.
Bug 1383478 was fixed. So, please use url https://bugzilla.mozilla.org/attachment.cgi?id=8878851 for step prepare-2.
Depends on: 1384094
Track 56+ as new regression.

Hi :kmag,
Can you help look at this issue?
Flags: needinfo?(kmaglione+bmo)
Bug 1380267 fixes the crash
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(kmaglione+bmo)
Resolution: --- → FIXED
Assignee: nobody → kmaglione+bmo
Target Milestone: --- → mozilla56
Product: Toolkit → WebExtensions
Depends on: 1509084
You need to log in before you can comment on or make changes to this bug.