Sometimes images suddenly turn blank

RESOLVED DUPLICATE of bug 1380649

Status

()

Core
Layout: Images
P3
normal
RESOLVED DUPLICATE of bug 1380649
10 months ago
8 months ago

People

(Reporter: mstange, Unassigned)

Tracking

({regression, steps-wanted})

Trunk
All
Mac OS X
regression, steps-wanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 months ago
Created attachment 8889169 [details]
github screenshot

I've seen this twice with the 2017-07-20 nightly on Mac.

In a place where there was an image before, suddenly there was just transparency.

The first time I saw this was on Twitter, at https://twitter.com/anatudor/status/888690391695884288 . The two large images inside that tweet were suddenly gone, and not only that, but they left a transparent hole in the tweet overlay. I was able to scroll the rest of my twitter timeline underneath, and see it through the holes left by the images.
I think this indicates that Layout thought that the images were opaque.

The second time I've seen it was on github, where all the user icons suddenly turned black. This happened as I was waking the machine from sleep: The first second, there were user icons in the right places, and then suddenly they were gone. I've attached a screenshot.
In the github case, if I inspect the img element with the devtools and then hover over the src attribute value, it shows me a preview of a completely blank image (it shows the transparency checkerboarding pattern). But if I load the URL of that image in a new tab, the image shows up correctly. A refresh of the page also fixed the issue.
(In reply to Markus Stange [:mstange] from comment #0)
> The second time I've seen it was on github, where all the user icons
> suddenly turned black. This happened as I was waking the machine from sleep:
> The first second, there were user icons in the right places, and then
> suddenly they were gone. I've attached a screenshot.
> In the github case, if I inspect the img element with the devtools and then
> hover over the src attribute value, it shows me a preview of a completely
> blank image (it shows the transparency checkerboarding pattern). But if I
> load the URL of that image in a new tab, the image shows up correctly. A
> refresh of the page also fixed the issue.

Hm, this sounds similar to bug 1380649. Clearly there is a problem related to sleep/resume.

Updated

9 months ago
Priority: -- → P3

Comment 2

8 months ago
I am seeing this frequently (multiple times a day), even without sleep/resume. For me, the trigger appears to be switching away from a tab and then switching back. The probability of the problem surfacing appears to be significantly higher if the page has many images on it. I can reproduce it pretty reliably by surfing around Flickr albums in one tab and CNN news stories in another, switching back and forth occasionally.
I believe this is fixed in the latest nightly by bug 1380649.
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1380649

Comment 4

8 months ago
Created attachment 8910328 [details]
Flickr without pictures
You need to log in before you can comment on or make changes to this bug.