[LeanPlum] - Promote focus is not triggered when opening a new tab after opening a private tab

RESOLVED INVALID

Status

()

Firefox for Android
General
RESOLVED INVALID
4 months ago
3 months ago

People

(Reporter: BogdanS, Assigned: nechen)

Tracking

(Blocks: 1 bug)

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(fennec-, firefox56 affected)

Details

(Whiteboard: [LP_M1])

(Reporter)

Description

4 months ago
Devices:
 - Nexus 5 (Android 6.0.1); 
 - Nexus 6 (Android 7.0);
 - Samsung Galaxy Note 4 (Android 5.0.1);

Prerequisits:
 Install Switchboard Experiments and enable LeanPlum. Make sure Focus is not installed.

Steps to reproduce:
1. Open Fennec and open a new private tab from the 3 dot menu or the tab tray;
2. Once the tab is opened, open a New Tab from the 3 dot menu or the tab tray.

Expected result:
 Promote Focus should be triggered.

Actual result:
 Promote Focus is not triggered.
(Assignee)

Comment 1

4 months ago
Hi Bogdan
Thanks for the report.
Actually we did this on purpose.
When a user 
a) open a private tab
b) current selected tab is a private tab
We won't send event to Leanplum.

When a new tab is opened after a private tab opened, the current selected tab is still a private tab.
Flags: needinfo?(bogdan.surd)
(Reporter)

Comment 2

4 months ago
Hello Nevin,

Closing the issue if this is the intended behavior, I thought the trigger should occur whenever a new tab is opened regardless of the fact that the user is currently in a private tab or not. Thank you for clearing that up.
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Flags: needinfo?(bogdan.surd)
Resolution: --- → INVALID
[traige@0716] - as invalid.
(Assignee)

Updated

4 months ago
tracking-fennec: ? → -
Whiteboard: [LP_M2]
Whiteboard: [LP_M2] → [LP_M1]
You need to log in before you can comment on or make changes to this bug.