Windows address sanitizer builds on TC missing symbols

RESOLVED DUPLICATE of bug 1360650

Status

RESOLVED DUPLICATE of bug 1360650
2 years ago
11 months ago

People

(Reporter: tsmith, Unassigned)

Tracking

Trunk

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
The windows address sanitizer builds on taskcluster seem to be missing symbols.

https://tools.taskcluster.net/index/artifacts/gecko.v2.mozilla-central.latest.firefox/win64-asan-opt

I do not see anything like: target.crashreporter-symbols-full.zip

Another possibility suggested by :froydnj is to not strip the symbols. This is current practice for our Linux ASan builds so it is preferred.
.... Sooo, I investigated briefly to make sure this bug doesn't block the Tier1-ing of Windows builds in Taskcluster this week.

I assert it does not, reasons follow.

* Asan for windows was enabled in https://hg.mozilla.org/mozilla-central/rev/ce6d44c6917e
* In that patch, we also *explicitly* disable symbol fetching on tests: https://hg.mozilla.org/mozilla-central/rev/ce6d44c6917e#l4.50
* That patch also sets 'run-on-projects: []' which means it shouldn't run on central (unless something else "selected" to run depends on it) and enables it to be runnable on try.
* That job had been running on central as recently as friday, I'm not certain why offhand.
** https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&revision=057d626fc5e1afbf4086eb9400ebb3718a4cabca&filter-searchStr=win+asan&filter-tier=1&filter-tier=2&filter-tier=3
* As of the autoland to central merge on saturday it has not been running
** https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&revision=7e496e6bac00d2acbf3dcd5615c13d4ac489724e&filter-searchStr=win+asan&filter-tier=1&filter-tier=2&filter-tier=3

Given all that I think if/when its deemed needed to run on central it can simply be enabled and this bug addressed if its a blocker.
Is this different from bug 1360650?
Flags: needinfo?(twsmith)
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(twsmith)
Resolution: --- → DUPLICATE
Duplicate of bug: 1360650
(Reporter)

Comment 4

2 years ago
(In reply to David Major [:dmajor] from comment #2)
> Is this different from bug 1360650?

Nope. it's just been a while an it slipped my mind sorry (on the plus side it got things moving).

Updated

11 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.