General - Browsing section has 5 options instead of 4

RESOLVED INVALID

Status

()

RESOLVED INVALID
a year ago
a year ago

People

(Reporter: brindusat, Unassigned)

Tracking

56 Branch
All
Windows
Points:
---

Firefox Tracking Flags

(firefox54 unaffected, firefox55 unaffected, firefox56 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8889864 [details]
BugBrowsing.jpg

[Affected versions]: 
Nightly 56.0a1, Build ID 20170724030204

[Affected platforms]:
Platforms: Windows 10 x 64, Mac OS X 10.12, Ubuntu 

[Steps to reproduce]:
1. Launch Nightly
2. Go to "about:preferences"
3. In the General tab check "Browsing" section

[Expected result]:
Browing section should contain 4 check boxes, as per spec: https://mozilla.invisionapp.com/share/P4ACQT1E3#/screens/217167547 :
- Use autoscrolling
- Use smooth scrolling
- Always use the cursor keys to navigate within pages
- Search for text when you start typing
See attached screenshot from specs


[Actual result]:
Browing section contains 5 check boxes:
- Use autoscrolling
- Use smooth scrolling
- Show a touch keyboard when necessary
- Always use the cursor keys to navigate within pages
- Search for text when you start typing
(Reporter)

Updated

a year ago
status-firefox54: --- → unaffected
status-firefox55: --- → unaffected
status-firefox56: --- → affected
Whiteboard: [photon-preference][triage]
Hi Brindusa,

According to comment from source code https://searchfox.org/mozilla-central/source/browser/components/preferences/in-content-new/main.js#966-979, this feature is only enabled on Windows

Could you help me confirm again that the issue will happen on Linux and macOS as well?

This bug might be an invalid issue since some of those options are platform specific. Please note that the spec is just for reference but the real situation might be different.
Flags: needinfo?(brindusa.tot)
Brindusa,

I'm going to close this issue since after confirmation on Windows laptop, this issue is a platform specific options only enabled on Windows and it's by design.

> [Affected platforms]:
> Platforms: Windows 10 x 64, Mac OS X 10.12, Ubuntu

I suspect that the `[Affected Platforms]` is an incorrect result since you were testing on Windows. Sorry for the confusion, the spec wasn't clear and included all possible options for all platforms.

Feel free to reopen the bug if you still believe this is indeed a problem. Thanks!
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
remove whiteboard tag due to its INVALID
Whiteboard: [photon-preference][triage]
(Reporter)

Comment 4

a year ago
(In reply to Ricky Chien [:rickychien] from comment #1)
> Hi Brindusa,
> 
> According to comment from source code
> https://searchfox.org/mozilla-central/source/browser/components/preferences/
> in-content-new/main.js#966-979, this feature is only enabled on Windows
> 
> Could you help me confirm again that the issue will happen on Linux and
> macOS as well?

Sorry for the confusion with the OS-es. You are right, this is only on Windows.

> 
> This bug might be an invalid issue since some of those options are platform
> specific. Please note that the spec is just for reference but the real
> situation might be different.


We do not take specs "just for reference". This spec (https://mozilla.invisionapp.com/share/P4ACQT1E3#/screens/217167547) is the only spec we have and we created the testcases based on it. Therefore, we are expecting implementation will comply with the specification.
Flags: needinfo?(brindusa.tot)
OS: All → Windows
You need to log in before you can comment on or make changes to this bug.