Stylo: Tab crash with Inspector open on https://daneden.github.io/animate.css/

RESOLVED DUPLICATE of bug 1384014

Status

()

Core
CSS Parsing and Computation
P1
normal
RESOLVED DUPLICATE of bug 1384014
9 months ago
9 months ago

People

(Reporter: clarkbw, Assigned: boris)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 months ago
Created attachment 8889974 [details]
Screen Shot 2017-07-24 at 12.00.05 PM.png

I get a consistent tab crash when viewing https://daneden.github.io/animate.css/ with the inspector open.  

I've attached the screenshot of the console log which refers to this line of code: https://searchfox.org/mozilla-central/source/browser/modules/FullZoomUI.jsm#60

I have the stylo pref turned on, here are some crash ids

5bfd4f54-43aa-454d-a964-882430170724
bp-d21e306b-a7da-4f4b-a128-c46ff0170724
bp-af076808-6840-4abb-ad02-c56ef0170724

With stylo turned on I can reproduce this with a fresh profile. ( bp-a9a3347a-e855-4141-babd-4feb10170725 )
(Reporter)

Comment 1

9 months ago
STR

1. open page https://daneden.github.io/animate.css/
2. open devtools inspector
3. open animations tab in inspector right sidebar
I believe the ZoomUI part is unrelated to the crash, seems like a Stylo content crash.
Blocks: 1375906, 1322657
Component: Location Bar → CSS Parsing and Computation
Product: Firefox → Core
Summary: Tab crash with Inspector open on https://daneden.github.io/animate.css/ → Stylo: Tab crash with Inspector open on https://daneden.github.io/animate.css/
Priority: -- → P1
DevTools is one of the two consumers of compute_distance (the other being SMIL) so it sounds like one of our compute_distance implementations is buggy. And based on bug 1384014 it looks like we're unwrapping something we shouldn't.
(Assignee)

Updated

9 months ago
Assignee: nobody → boris.chiou
(Assignee)

Updated

9 months ago
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1384014
You need to log in before you can comment on or make changes to this bug.