Closed Bug 1384242 Opened 3 years ago Closed 3 years ago

stylo: Assertion failure: !(isInitial || forReconstruct || forNewlyBoundElement) || !postTraversalRequired

Categories

(Core :: CSS Parsing and Computation, defect, P1)

defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: truber, Unassigned)

References

(Blocks 2 open bugs)

Details

(Keywords: assertion, testcase)

Attachments

(1 file)

Attached file testcase.html
The attached testcase causes an assertion in m-c rev 07484bfdb96b with stylo enabled by pref and e10s disabled.

[31352] WARNING: Cannot switch to prerendered document in the parent process: file /home/worker/workspace/build/src/xpfe/appshell/nsContentTreeOwner.cpp, line 446
Assertion failure: !(isInitial || forReconstruct || forNewlyBoundElement) || !postTraversalRequired, at /home/worker/workspace/build/src/layout/style/ServoStyleSet.cpp:302
#01: mozilla::ServoStyleSet::StyleDocument at layout/style/ServoStyleSet.cpp:803
#02: nsCSSFrameConstructor::ConstructDocElementFrame at layout/style/StyleSetHandle.h:199
#03: nsCSSFrameConstructor::ContentRangeInserted at layout/base/nsCSSFrameConstructor.cpp:8047
#04: nsCSSFrameConstructor::ContentInserted at layout/base/nsCSSFrameConstructor.h:277
#05: mozilla::PresShell::ContentInserted at dom/base/nsINode.h:576
#06: nsNodeUtils::ContentInserted at dom/base/nsNodeUtils.cpp:201
#07: nsINode::doInsertChildAt at dom/base/nsINode.cpp:1640
#08: nsINode::ReplaceOrInsertBefore at dom/bindings/ErrorResult.h:376
#09: mozilla::dom::NodeBinding::replaceChild at obj-firefox/dom/bindings/NodeBinding.cpp:946
#10: mozilla::dom::GenericBindingMethod at dom/bindings/BindingUtils.cpp:3062
#11: js::CallJSNative at js/src/jscntxtinlines.h:293
#12: js::InternalCallOrConstruct at js/src/vm/Interpreter.cpp:470
#13: Interpret at js/src/vm/Interpreter.cpp:3066
#14: js::RunScript at js/src/vm/Interpreter.cpp:381
#15: js::InternalCallOrConstruct at js/src/vm/Interpreter.cpp:488
#16: js::Call at js/src/vm/Interpreter.cpp:534
#17: JS::Call at js/src/jsapi.cpp:2948
#18: mozilla::dom::EventHandlerNonNull::Call at obj-firefox/dom/bindings/EventHandlerBinding.cpp:260
#19: mozilla::JSEventHandler::HandleEvent at obj-firefox/dist/include/mozilla/dom/EventHandlerBinding.h:357
#20: mozilla::EventListenerManager::HandleEventSubType at dom/events/EventListenerManager.cpp:1143
#21: mozilla::EventListenerManager::HandleEventInternal at dom/events/EventListenerManager.cpp:1311
#22: mozilla::EventTargetChainItem::HandleEvent at dom/events/EventListenerManager.h:376
#23: mozilla::EventTargetChainItem::HandleEventTargetChain at dom/events/EventDispatcher.cpp:464
#24: mozilla::EventDispatcher::Dispatch at dom/events/EventDispatcher.cpp:829
#25: nsDocumentViewer::LoadComplete at layout/base/nsDocumentViewer.cpp:1118
#26: nsDocShell::EndPageLoad at docshell/base/nsDocShell.cpp:7718
#27: nsDocShell::OnStateChange at docshell/base/nsDocShell.cpp:7515
#28: nsDocLoader::DoFireOnStateChange at uriloader/base/nsDocLoader.cpp:1299
#29: nsDocLoader::doStopDocumentLoad at uriloader/base/nsDocLoader.cpp:859
#30: nsDocLoader::DocLoaderIsEmpty at uriloader/base/nsDocLoader.cpp:751
#31: nsDocLoader::OnStopRequest at uriloader/base/nsDocLoader.cpp:631
#32: mozilla::net::nsLoadGroup::RemoveRequest at netwerk/base/nsLoadGroup.cpp:631
#33: nsDocument::DoUnblockOnload at dom/base/nsDocument.cpp:8934
#34: nsDocument::UnblockOnload at dom/base/nsDocument.cpp:8855
#35: nsDocument::DispatchContentLoadedEvents at dom/base/nsDocument.cpp:5307
Flags: in-testsuite?
Priority: -- → P1
I can't reproduce this assertion on current mozilla-central, though I could with the revision mentioned in comment 0.  The assertion has changed slightly (though not related to the way it was failing before, which was due to isInitial being true).  Other changes might have fixed this.

Resolving this WORKSFORME, then.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.