Text Zoom is really slow

RESOLVED DUPLICATE of bug 138436

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 138436
16 years ago
14 years ago

People

(Reporter: yusei, Assigned: Matti)

Tracking

({regression})

Trunk
x86
Linux
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Text Zoom freezes the browser for a few seconds on complex pages, while it
didn't with mozilla 0.9.9
Confirm it happens on linux with mozilla r.0rc1 Gecko/20020417.
Dont know about win32 yet.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

16 years ago
Works with build 2002041803 on win-xp.
Keywords: regression

Comment 3

16 years ago
Works for me. At least I only get around 1sec delay on rather complex pages
(e.g. slashdot, www.spiegel.de), using 1.0rc1 on w2k.

Comment 4

16 years ago
We need a good testcase here that everyone will freeze on. Are there any extreme
cases where this will be visible for most users (even with fast computers) ?

Comment 5

16 years ago
This URL takes mozilla over 30 seconds on my 1GHz (CPU-intensive, RAM usage
unchanging): http://www.wincustomize.com/news_comments_full.asp?NewsID=765

This is build 2002041617 (1.0.0 branch).

Comment 6

16 years ago
First, I should correct myself: it definitely takes more than a minute or two on
the page I mentioned.

I ran a debug build from CVS (6pm EST, 15 April -- 2002041518; no specific
branch) and kill -SEGV'ed it about 10 seconds into the freeze to force a core
dump.  GDB cannot produce a complete backtrace: it gets to #267 and is killed. 
I'm attaching the whole of what I got (~61KiB) because I can't make enough sense
of it to know what could be cut out.

Bug 138436 seems similar to this (I got the URL from a Mozillazine comment).

Comment 7

16 years ago
Created attachment 80225 [details]
Stack trace of debug build showing lots of recursion

I snipped out all the symbol loading messages to reduce clutter
(Assignee)

Comment 8

16 years ago
duping against bzg 138436 (already assigned to layout)


*** This bug has been marked as a duplicate of 138436 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.