Closed Bug 1384470 Opened 2 years ago Closed 2 years ago

General " Files and Applications" inconsistency between spec and latest build for the word "Web"

Categories

(Firefox :: Preferences, defect, P1)

56 Branch
Unspecified
All
defect

Tracking

()

VERIFIED FIXED
Firefox 56
Tracking Status
firefox56 --- fixed

People

(Reporter: miriapodzemos.my, Assigned: evanxd)

References

Details

(Whiteboard: [photon-preference])

Attachments

(1 file)

[Affected versions]: 
Nightly 56.0a1, Build ID 20170723100358

[Affected platforms]:
Platforms: Windows 10 x 64 and Mac OS X 10.12

[Steps to reproduce]:
1. Launch Nightly
2. Go to "about:preferences"
3. In the General tab check "Files and Applications" section - "Applications"

[Expected result]:
String changed to: "Choose how Nightly handles the files you download from the web or the applications you use while browsing." ("Web" > "web") - "web" lowercase letter per spec https://mozilla.invisionapp.com/share/P4ACQT1E3#/screens/217167547

[Actual result]:
"Choose how Nightly handles the files you download from the Web or the applications you use while browsing."  "Web" - Capital letter
Blocks: 1365133
Whiteboard: [photon-preference][triage]
Assignee: nobody → evan
Status: NEW → ASSIGNED
Flags: qe-verify+
Priority: -- → P1
QA Contact: hani.yacoub
Whiteboard: [photon-preference][triage] → [photon-preference]
Target Milestone: --- → Firefox 56
Attachment #8890251 - Flags: review?(mconley)
Hi Mike,

Could you help review the patch of changing a string?

Thank you.
Comment on attachment 8890251 [details]
Bug 1384470 - The w letter of "web" string should be lowercase.

https://reviewboard.mozilla.org/r/161376/#review166788

Thanks!

::: browser/locales/en-US/chrome/browser/preferences/applications.dtd:6
(Diff revision 1)
>  <!-- This Source Code Form is subject to the terms of the Mozilla Public
>     - License, v. 2.0. If a copy of the MPL was not distributed with this
>     - file, You can obtain one at http://mozilla.org/MPL/2.0/. -->
>  
>  <!ENTITY  applications.label       "Applications">
> -<!ENTITY  applications.description "Choose how &brandShortName; handles the files you download from the Web or the applications you use while browsing.">
> +<!ENTITY  applications.description "Choose how &brandShortName; handles the files you download from the web or the applications you use while browsing.">

I suppose since we're just changing case here, we don't need to worry about updating the key.

Will needinfo? flod to confirm on that. If he confirms, feel free to drop this issue and land.

Thanks evanxd!
Attachment #8890251 - Flags: review?(mconley) → review+
Hey flod,

Just double-checking here - we don't need to update the key if we're just changing the casing in a string, right?
Flags: needinfo?(francesco.lodolo)
Confirmed, for case and typos just update the string content
https://developer.mozilla.org/en-US/docs/Mozilla/Localization/Localization_content_best_practices#Changing_existing_strings
Flags: needinfo?(francesco.lodolo)
Thanks - you're good to go, evanxd.
Thank you for review the patch, Mike. Let's land it.
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/8315c95af78c
The w letter of "web" string should be lowercase. r=mconley
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/8315c95af78c
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
I tested this issue on Windows 10, 7, Mac OS X 10.12 and Ubuntu 16.04 with FF Nightly 56.0a1(2017-07-28) and I can't reproduce it. I will mark this as Verified Fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.