All users were logged out of Bugzilla on October 13th, 2018

browser/base/content/test/general/browser_save_video.js fails when we enable rcwn

RESOLVED FIXED in Firefox 57

Status

()

RESOLVED FIXED
a year ago
a year ago

People

(Reporter: juhsu, Assigned: michal.novotny)

Tracking

(Blocks: 1 bug)

unspecified
mozilla57
Points:
---

Firefox Tracking Flags

(firefox57 fixed)

Details

(Whiteboard: [necko-active])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

a year ago
RCWN would break the test by the following command

mach mochitest --setpref network.http.rcwn.enabled=true  browser/base/content/test/general/browser_save_video.js
(Reporter)

Comment 1

a year ago
Assign myself first. Feel free to take it.
Assignee: nobody → juhsu
Whiteboard: [necko-active]
(Reporter)

Comment 2

a year ago
"Save Video As" functional works in nightly.
Summary: "Save Video As" not working when we enable rcwn → browser/base/content/test/general/browser_save_video.js fails when we enable rcwn
(Reporter)

Comment 3

a year ago
Created attachment 8902633 [details] [diff] [review]
disable-rcwn-save-video, v1

Hello Paolo,
Since save_video_as works well in nightly with rcwn and we
don't have a fix after survey, we'd like to disable rcwn in this test.

Could you review my patch please? Thanks.
Attachment #8902633 - Flags: review?(paolo.mozmail)

Comment 4

a year ago
Comment on attachment 8902633 [details] [diff] [review]
disable-rcwn-save-video, v1

From the looks of the test, I don't see how enabling RCWN can make the test fail, other than a race condition for which some expected progress events are not dispatched, which would be a bug in the RCWN implementation.

How did you determine that "Save Video As" works in Nightly? If you just tested it manually, it's quite possible that it only works because you wait some time before invoking the command, and maybe it would actually fail on larger videos or certain network conditions.
Attachment #8902633 - Flags: review?(paolo.mozmail) → review-
(Reporter)

Comment 5

a year ago
> How did you determine that "Save Video As" works in Nightly? If you just
> tested it manually, it's quite possible that it only works because you wait
> some time before invoking the command, and maybe it would actually fail on
> larger videos or certain network conditions.

Yes by manual test.
(Assignee)

Comment 6

a year ago
I had a look at the failure and the channel really doesn't provide any data. The problem is that the cache entry is nulled out at http://searchfox.org/mozilla-central/rev/51b3d67a5ec1758bd2fe7d7b6e75ad6b6b5da223/netwerk/protocol/http/nsHttpChannel.cpp#1722.
(Assignee)

Comment 7

a year ago
Created attachment 8902991 [details] [diff] [review]
fix
Assignee: juhsu → michal.novotny
Attachment #8902633 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #8902991 - Flags: review?(honzab.moz)
Attachment #8902991 - Flags: review?(honzab.moz) → review+

Comment 8

a year ago
Pushed by mnovotny@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/d1768de3e9f2
browser/base/content/test/general/browser_save_video.js fails when we enable rcwn, r=honzab
https://hg.mozilla.org/mozilla-central/rev/d1768de3e9f2
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
status-firefox57: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
You need to log in before you can comment on or make changes to this bug.