The original bookmark location will be changed after logging in to the new device

RESOLVED DUPLICATE of bug 1352233

Status

Cloud Services
Firefox Sync: Cross-client
RESOLVED DUPLICATE of bug 1352233
a year ago
a year ago

People

(Reporter: yxu, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

3.79 KB, image/png
Details
4.60 KB, image/png
Details
(Reporter)

Description

a year ago
Created attachment 8890252 [details]
step 1

Reproduce steps:

1.I have added some bookmarks in the bookmarks toolbar, and customize single bookmarks and folders in the order I want. I referred to it as "Profile 1". See attachment step 1.

2.After that I log in my Firefox Account on a new device or a new profile. Referred to as "Profile 2". At this time the synchronization of the bookmark will put the folder on the front, single bookmarks behind, regardless of the previous order. See attachment step 2.

3.And if I go back to Profile 1, then the location of the folder because of Profile 2, has just become the "folder on the front" arrangement. Just like Profile 2.
(Reporter)

Comment 1

a year ago
Created attachment 8890254 [details]
step 2
yxu, can you reproduce this with both Profile 1 and Profile 2 being desktop devices?
Blocks: 621584
Flags: needinfo?(yxu)
Blocks: 1353641
There's a good chance this is bug 1352233, fixed in 55.
(Reporter)

Comment 4

a year ago
55.0b12   20170724055319
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0

I tested the performance on the 55beta. At the beginning of the synchronization still the folder on the front, single bookmarks behind. But will immediately adjust back to the original order. The order of the Profile 1 will not be changed. It works as I expected. Due to the bug 1352233. Thank you Mark.

If we want to refine, I hope that at the beginning of the synchronization, the bookmarks can also be displayed in the original order, rather than as it shows in a chaotic way at first and then adjusts. 

I'm not sure if there are other considerations behind this (for example, maybe our synchronization logic is to synchronize the folder first). First of all, this will make users to worry about, even if only a moment. And if the network just be broken at this time, whether the bookmark will still be as I show before.
Flags: needinfo?(yxu)
(In reply to yxu from comment #4)
> If we want to refine, I hope that at the beginning of the synchronization,
> the bookmarks can also be displayed in the original order, rather than as it
> shows in a chaotic way at first and then adjusts. 
> 
> I'm not sure if there are other considerations behind this (for example,
> maybe our synchronization logic is to synchronize the folder first). First
> of all, this will make users to worry about, even if only a moment. And if
> the network just be broken at this time, whether the bookmark will still be
> as I show before.

Thanks for getting back to us. The way we do things now isn't ideal, but should re-adjust if the sync is interrupted - however, we are actively working on a better approach to this, which may make 57 but will almost certainly be in 58.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1352233
You need to log in before you can comment on or make changes to this bug.