Status

RESOLVED FIXED
a year ago
6 months ago

People

(Reporter: public, Assigned: MakeMyDay)

Tracking

({regression})

Lightning 5.4.2.1
5.4.3
regression

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Regression of bug 1280898: https://hg.mozilla.org/comm-central/diff/fd02e757b142/calendar/import-export/calOutlookCSVImportExport.js

The variable 'locale' has been moved to a tighter scope, but is still used afterwards. Also note that the "nl" locale has been used for the Outlook 2000 format (last loop iteration, without breaking), seems like a bad default to me.

STR:
0. Thunderbird 52.2.1
1. Open the error console
2. Import a supported CSV file (manually creating it if your version and locale from Outlook is not supported)

Expected:
The import succeeds, no messages in the error console.

Actual:
The import does not work, error console:
[Exception... "[JavaScript Error: "locale is not defined" {file: "resource://calendar/modules/calUtils.jsm -> file:///C:/Users/xxxxx/AppData/Roaming/Thunderbird/Profiles/aw03o5my.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calOutlookCSVImportExport.js" line: 245}]'[JavaScript Error: "locale is not defined" {file: "resource://calendar/modules/calUtils.jsm -> file:///C:/Users/xxxxx/AppData/Roaming/Thunderbird/Profiles/aw03o5my.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calOutlookCSVImportExport.js" line: 245}]' when calling method: [calIImporter::importFromStream]" nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)" location: "JS frame :: chrome://calendar/content/import-export.js :: loadEventsFromFile :: line 85" data: yes]

(Taken from a German Thunderbird forum, see attached url for the original post in German)
Version: Trunk → Lightning 5.4.2.1
(Assignee)

Comment 1

a year ago
Confirming by code inspection. The issue still exists in trunk.
Blocks: 1280898
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
See Also: bug 1280898
(Assignee)

Comment 2

a year ago
Created attachment 8891692 [details] [diff] [review]
FixOLCsvImport-V1.diff

This patch takes care and removes an unneccessary check for a time parameter as there exists code for handling that specific case later on.
Assignee: nobody → makemyday
Status: NEW → ASSIGNED
Attachment #8891692 - Flags: review?(mschroeder)
Attachment #8891692 - Flags: review?(mschroeder)
Attachment #8891692 - Flags: review+
Attachment #8891692 - Flags: approval-calendar-esr?(philipp)
Attachment #8891692 - Flags: approval-calendar-beta?(philipp)
Keywords: checkin-needed

Comment 3

a year ago
You have some strange characters in the patch, "hg out" gives:
summary:     ´╗┐Bug 1384587 - Outlook CSV import is broken;r=mschroeder

Comment 4

a year ago
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/efffc843dbfa
Outlook CSV import is broken. r=mschroeder
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Keywords: checkin-needed
Resolution: --- → FIXED

Updated

a year ago
Target Milestone: --- → 5.8
Attachment #8891692 - Flags: approval-calendar-esr?(philipp)
Attachment #8891692 - Flags: approval-calendar-esr+
Attachment #8891692 - Flags: approval-calendar-beta?(philipp)
Attachment #8891692 - Flags: approval-calendar-beta+
(Assignee)

Updated

6 months ago
Duplicate of this bug: 1439210
You need to log in before you can comment on or make changes to this bug.