Pocket doesn't work with privacy.firstparty.isolate set to true

RESOLVED FIXED in Firefox 66

Status

()

defect
P3
normal
RESOLVED FIXED
2 years ago
5 months ago

People

(Reporter: mostlygeek, Assigned: Gijs)

Tracking

(Blocks 2 bugs)

55 Branch
Firefox 66
x86
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox66 fixed)

Details

(Whiteboard: [tor])

Attachments

(1 attachment)

Reporter

Description

2 years ago
With the pref: privacy.firstparty.isolate=true, clicking the pocket button on the toolbar will bring to getpocket.com and your list. 

The expected behavior is for pocket to actually add the page to my list.
Assignee

Comment 1

2 years ago
Tom, do you know (someone who knows) why this would be?

(De-prio'ing as this isn't going to hit many people and this has shipped for a while now.)
Flags: needinfo?(tom)
Priority: -- → P3

Comment 2

2 years ago
I don't know personally, but I'm adding the team who can figure it out.
Flags: needinfo?(tom)

Updated

2 years ago
Flags: needinfo?(ettseng)
(In reply to Tom Ritter [:tjr] from comment #2)
> I don't know personally, but I'm adding the team who can figure it out.

Thanks, Tom!

Tim, please look into this bug to see how we can fix the problem.
Thanks.
Assignee: nobody → tihuang
Flags: needinfo?(ettseng)
Whiteboard: [tor]
I cannot reproduce the same issue that comment 0 describes, but I did find something wrong here. Pocket won't save the page if the first party isolation is enabled. 

STR:
1. Turn on the pref 'privacy.firstparty.isolate'.
2. Login the pocket either by clicking the pocket button or visiting the website.
3. Open any page that you are ready to save.
4. Click the pocket button.

Expected behavior:
  Pocket adds the page.

Actual behavior:
  The pocket panel shows up as non-login and the page is not saved.

The root cause of this problem is that Pocket is using the default originAttributes, but the login cookies will be put under originAttributes {firtPartyDomain: "getpocket.com"} when first party isolation is enabled. So, Pocket cannot access the cookies which leads to this issue.

Benson, is this the same STR of the problem you reported. If it is not, could you provide details of how to reproduce the problem you encountered, Thanks.
Flags: needinfo?(bwong)
Reporter

Comment 5

2 years ago
I tried reproducing on FF57.0b4 and could not. 
With privacy.firstparty.isolate = true, I was able to add pages to my pocket.
Flags: needinfo?(bwong)
If Benson can't repro, going to mark this as fixed.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED

Comment 7

a year ago
I'm still getting this bug on Firefox 59. When I first enabled first party isolation, Pocket seemed to work fine. However, it broke after clearing all of my cookies and I can't get it working again. I think you need to clear your cookies in order to properly reproduce the problem.
(In reply to sslanec from comment #7)
> I'm still getting this bug on Firefox 59. When I first enabled first party
> isolation, Pocket seemed to work fine. However, it broke after clearing all
> of my cookies and I can't get it working again. I think you need to clear
> your cookies in order to properly reproduce the problem.

This sounds like Pocket is retrieve cookies from your default cookie jar and ignoring FPI.  Thus when you set FPI to on, things still work; but if you clear your cookies; things will break.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

a year ago
Assignee: artines1 → nobody

Comment 9

a year ago
I’m also seeing this exact same problem on Firefox 60. It works if I login to Pocket as the first thing I do in a new profile. However, I can’t first enable first-party isolation and then login to Pocket.
So this isn't a bug with FPI; it's a bug with Pocket's session handling code. I'm going to try to figure out how to get this to Pocket...
Flags: needinfo?(matt)

Updated

a year ago
Flags: needinfo?(matt)

Comment 11

a year ago
Tom - Thanks for sending over. I think this initially came through before we had good clarity on triaging Pocket issues in Bugzilla. Adding Justin Rochell from our team who takes the lead on triaging and might have some additional questions.

Comment 12

a year ago
Thanks for the ping. 

Yep, we've been tracking this. Users occasionally encounter this issue when they enable First Party Isolation and try to use Pocket.

Tom - could you please outline your findings with our session handling code? I'm happy to make sure it gets into the proper hands.
(In reply to Justin Rochell from comment #12)
> Thanks for the ping. 
> 
> Yep, we've been tracking this. Users occasionally encounter this issue when
> they enable First Party Isolation and try to use Pocket.
> 
> Tom - could you please outline your findings with our session handling code?
> I'm happy to make sure it gets into the proper hands.

A really cursory search of 'cookie' in pocket turns up https://searchfox.org/mozilla-central/rev/3737701cfab93ccea04c0e9cab211ad10f931d87/browser/extensions/pocket/content/pktApi.jsm#157

I think you would want to update that to look to see if FPI is currently enabled; and if so, to pass in OriginAttributes data to retrieve the Pocket Cookies from FPI.  This means that the user will be logged out of Pocket when they turn on FPI; but they're logged out of everything else so it will probably be normal to them.
Duplicate of this bug: 1473738

Comment 15

5 months ago
Experiencing this issue on Firefox Developer Edition 65.0b4. When FPI is enabled can't save page to Pocket even if already logged in to Pocket.

Screenshot: https://i.imgur.com/H0w0EFb.png
Tim, we need to re-investigate this issue. Please take a look when you have time.
Flags: needinfo?(tihuang)

Comment 17

5 months ago
Since I haven't seen any indication otherwise, I believe the issue is still in Pocket's court to fix; per Comment 13.
Flags: needinfo?(tihuang)
Assignee

Updated

5 months ago
Assignee: nobody → gijskruitbosch+bugs
Status: REOPENED → ASSIGNED

Comment 19

5 months ago
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/623fa9efc465
fix pocket when cookie first party isolation has been turned on, r=tjr,thecount

Comment 20

5 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/623fa9efc465
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66
You need to log in before you can comment on or make changes to this bug.