Compilation breaks because nsTextFrame.cpp doesn't find nsILE.h in line 105

VERIFIED DUPLICATE of bug 133212

Status

SeaMonkey
Build Config
--
blocker
VERIFIED DUPLICATE of bug 133212
16 years ago
12 years ago

People

(Reporter: Deleted User, Assigned: hacker formerly known as seawood@netscape.com)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020312
BuildID:    ???? RC1

I can't compile the new mozilla release from source because some header seems to
be missing. I can't describe more because I don't know more about it. Below you
get some information about my system:

Linux orgc 2.4.16 #3 Mit Mär 27 16:34:35 CET 2002 i686 unknown
 
Gnu C                  2.95.3
Gnu make               3.79.1
binutils               2.11.2
util-linux             2.11i
mount                  2.11i
modutils               2.4.12
e2fsprogs              1.25
PPP                    2.4.1
Linux C Library        2.2.4
Dynamic linker (ldd)   2.2.4
Procps                 2.0.7
Net-tools              1.60
Kbd                    1.06
Sh-utils               2.0

That was my configuration:

./configure --prefix=/usr/mozilla --with-pthreads --enable-crypto
--enable-xinerama --enable-ctl --disable-dtd-debug --enable-crash-on-assert
--enable-reorder --enable-xterm-updates
--enable-default-mozilla-five-home=/usr/mozilla/bin 


Reproducible: Always
Steps to Reproduce:
1. untar the archive
2. configure the archive
3. type make and press enter
4. wait some hours

Actual Results:  directory: layout/html/base/src

nsTextFrame.cpp:105: nsILE.h: File or directory not found
nsTextFrame.cpp: In method `nsresult
nsTextFrame::IsVisibleForPainting(nsIPresContext *, nsIRenderingContext &, int,
PRBool *)':
nsTextFrame.cpp:2170: warning: unused variable `class nsIStyleContext * sc'
nsTextFrame.cpp: In method `void nsTextFrame::PaintUnicodeText(nsIPresContext *,
nsIRenderingContext &, nsIStyleContext *, nsTextFrame::TextStyle &, int, int)':
nsTextFrame.cpp:2342: `NS_ULE_CID' undeclared (first use this function)
nsTextFrame.cpp:2342: (Each undeclared identifier is reported only once
nsTextFrame.cpp:2342: for each function it appears in.)
nsTextFrame.cpp:2344: `nsILE' undeclared (first use this function)
nsTextFrame.cpp:2344: template argument 1 is invalid
nsTextFrame.cpp:2344: warning: ANSI C++ forbids declaration `mCtlObj' with no type
nsTextFrame.cpp:2345: `const class nsCreateInstanceByCID' used where a `int' was
expected
nsTextFrame.cpp:2354: base operand of `->' is not a pointer
nsTextFrame.cpp:2363: base operand of `->' is not a pointer
nsTextFrame.cpp: In method `nsresult nsTextFrame::PeekOffset(nsIPresContext *,
nsPeekOffsetStruct *)':
nsTextFrame.cpp:4040: template argument 1 is invalid
nsTextFrame.cpp:4040: warning: ANSI C++ forbids declaration `mCtlObj' with no type
nsTextFrame.cpp:4041: `const class nsCreateInstanceByCID' used where a `int' was
expected
nsTextFrame.cpp:4058: base operand of `->' is not a pointer
nsTextFrame.cpp:4083: template argument 1 is invalid
nsTextFrame.cpp:4083: warning: ANSI C++ forbids declaration `mCtlObj' with no type
nsTextFrame.cpp:4084: `const class nsCreateInstanceByCID' used where a `int' was
expected
nsTextFrame.cpp:4102: base operand of `->' is not a pointer
nsTextFrame.cpp: In method `nsReflowStatus
nsTextFrame::MeasureText(nsIPresContext *, const nsHTMLReflowState &,
nsTextTransformer &, nsILineBreaker *, nsTextFrame::TextStyle &,
nsTextFrame::TextReflowData &)':
nsTextFrame.cpp:4982: warning: unused variable `int unused'
make[5]: *** [nsTextFrame.o] Error 1
make[4]: *** [libs] Error 2


Expected Results:  build finished

Please give hints
This is due to the --enable-ctl that you have...  Is nsILE.h not being placed in
dist/include/ctl ?

*** This bug has been marked as a duplicate of 133212 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

16 years ago
No, it isn't. There is nothing related to ctl in dist/include. I will now try
without this option.

Comment 4

16 years ago
looks like a dup to me.  verified/dup.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.