Closed Bug 1384870 Opened 4 years ago Closed 4 years ago

Update snack-bar when editing folders

Categories

(Firefox for Android Graveyard :: General, defect)

56 Branch
ARM
Android
defect
Not set
normal

Tracking

(fennec+, firefox56- disabled, firefox57+ disabled, firefox58 verified)

VERIFIED FIXED
Firefox 58
Tracking Status
fennec + ---
firefox56 - disabled
firefox57 + disabled
firefox58 --- verified

People

(Reporter: sflorean, Assigned: jwu, NeedInfo)

References

Details

(Whiteboard: [FNC][SPT58.1][INT])

Attachments

(1 file)

Environment: 
Device: Motorola Nexus 6 (Android 7.0);
Build: Nightly 56.0a1 (2017-07-26);

Steps to reproduce:
1. Launch Fennec and make a new folder A;
2. Long tap on it and choose Edit;
3. Change the name and tap on save button.

Expected result:
A snack-bar is displayed on bottom of the screen with the message "Folder updated". 

Actual result:
A snack-bar is displayed on bottom of the screen with the message "Bookmark updated".
Hi :jwu,

Would you help to check on this bug, please? Thanks
Flags: needinfo?(topwu.tw)
No problem, this bug would be fixed in 57 nightly since bookmark management is pref-off in 56.
Assignee: nobody → topwu.tw
Flags: needinfo?(topwu.tw)
tracking-fennec: ? → +
Moving the tracking nom to 56, I am assuming that was the intention. If it isn't fixed by the time 56 goes live, we can also track it for 57.
Per comment #2, since bookmark management is pref-off in 56, this bug won't happen in 56. Mark 56 as disabled. After discussing with dev, the feature is only enabled in nightly.
Tracked for 57. Hi Vance, will this feature ride the 57 train?
Flags: needinfo?(vchen)
This bug is bookmark management related, which is disabled in 57 because of some sync issues. As I know, for now bookmark management is scheduled to be enabled in 58.
Comment on attachment 8913069 [details]
Bug 1384870 - Show 'Folder updated' in snack bar after editing a bookmark folder.

https://reviewboard.mozilla.org/r/184474/#review189638
Attachment #8913069 - Flags: review?(cnevinchen) → review+
Pushed by topwu.tw@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/fe21efcf224e
Show 'Folder updated' in snack bar after editing a bookmark folder. r=nechen
https://hg.mozilla.org/mozilla-central/rev/fe21efcf224e
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
Verified as fixed in build 58.0a1 (2017-10-11);
Devices: Google Pixel (Android 8.0) and Sony Xperia Z5 Premium (Android 6.0.1).
"Folder updated" is displayed when editing a folder.
Whiteboard: [FNC][SPT58.1][INT]
Status: RESOLVED → VERIFIED
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.