“Undo” button which reverses the “Restart” action makes no sense in Legacy Extensions tab

RESOLVED INVALID

Status

()

Toolkit
Add-ons Manager
RESOLVED INVALID
7 months ago
7 months ago

People

(Reporter: Vasilica Mihasca, QA [away for an extended period of time - please needinfo addonsqa@softvision.ro], Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox54 unaffected, firefox55 disabled, firefox56 affected)

Details

Attachments

(1 attachment)

Created attachment 8890843 [details]
2017-07-27_1627.png

[Affected versions]:
Firefox 56.0a1 (2017-07-26)

[Affected platforms]:
Windows 10 64-bit
Ubuntu 16.04 32-bit

[Steps to reproduce]:
1.Launch Firefox with a clean profile.
2.Install the following legacy add-on: https://addons.mozilla.org/en-US/firefox/addon/google-translator-for-firefox/?src=cb-dl-users
3.Restart the browser.
4.Navigate to about:config and toggle "extensions.legacy.enabled” pref to false.
5.Go to about:addons -> Legacy Extensions tab and click on “Undo” button.


[Expected Results]:
“Undo” button which reverses the “Restart” action is not displayed in Legacy Extensions tab because it basically has no role, the user being forced to restart the browser in order to complete the add-on disabling process.

[Actual Results]:
- “Undo” button which reverses the “Restart” action appears in Legacy Extensions tab and nothing happens when clicking on it. 
- See attached screenshot.

[Additional notes]:
I am aware that after toggling the pref a restart must be performed but this scenario will be encountered when the browser will be updated from a version with "extensions.legacy.enabled” pref set to true to a new version with the pref set to false.

Comment 1

7 months ago
(In reply to Vasilica Mihasca, QA [:vasilica_mihasca] from comment #0)
> I am aware that after toggling the pref a restart must be performed but this
> scenario will be encountered when the browser will be updated from a version
> with "extensions.legacy.enabled” pref set to true to a new version with the
> pref set to false.

Can you elaborate on this?  When changing the version, the browser is of course restarted and incompatible addons will never be enabled in the new version.
Flags: needinfo?(vasilica.mihasca)
(In reply to Andrew Swan [:aswan] from comment #1)

> Can you elaborate on this?  When changing the version, the browser is of
> course restarted and incompatible addons will never be enabled in the new
> version.

I never mentioned that incompatible add-ons will be enabled in the new version, just that the ones which require restart will need a second restart in order to be completely disabled and in this case the “Undo” button does not make sense. 


Additional steps:
1.Launch Firefox with a clean profile.
2.Install the following legacy add-on: https://addons.mozilla.org/en-US/firefox/addon/noscript/?src=cb-dl-users
3.Close the browser.
4.Create a user.js file in the profile folder and save the following line: user_pref("extensions.legacy.enabled", false);
5.Open the firefox and navigate to about:addons -> Legacy Extensions tab.

The add-on is automatically moved to “Legacy Extensions” tab but it is still enabled. After a few seconds/minutes the “Restart now” and the unnecessary “Undo” links will appear in order to complete the disabling process.


Let’s imagine the following case:
- We run Firefox 56.0a1 with extensions.legacy.enabled set to true by default and with an add-on which requires restart installed.
- We receive a notification to update our Nightly to a build (we can consider 57.0a1) which will have extensions.legacy.enabled set to false by default
- We restart the browser in order to apply the updates.
- The add-on will be automatically moved to “Legacy Extensions” tab and the “Restart now” + “Undo” links will be displayed because another restart is needed in order to disable the add-on.
Flags: needinfo?(vasilica.mihasca)

Comment 3

7 months ago
(In reply to Vasilica Mihasca, QA [:vasilica_mihasca] from comment #2)
> > Can you elaborate on this?  When changing the version, the browser is of
> > course restarted and incompatible addons will never be enabled in the new
> > version.
> 
> I never mentioned that incompatible add-ons will be enabled in the new
> version, just that the ones which require restart will need a second restart
> in order to be completely disabled and in this case the “Undo” button does
> not make sense. 

Maybe I misunderstood but if you expect that a second restart will be needed, doesn't that mean the extension remains enabled after the first restart?  If the extension is not enabled after the first restart then there's no need for a second restart...
Tested using update test builds from https://bugzilla.mozilla.org/show_bug.cgi?id=1385964#c1 and it seems that the add-on is automatically disabled and there is no need for another restart. Based on this I am marking this bug as Invalid.
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.