If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Re-enable Stylo Linux debug tests impacted by Cairo leak

RESOLVED DUPLICATE of bug 1384701

Status

()

Core
CSS Parsing and Computation
P4
normal
RESOLVED DUPLICATE of bug 1384701
2 months ago
14 days ago

People

(Reporter: jryans, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Stylo])

(Reporter)

Description

2 months ago
Some test are failing at shutdown for the Linux64 debug e10s-off parallel config.

Bug 1384701 tracks the crash.  We should re-enable the runs once that is fixed.
We may be able to WONTFIX this bug because e10s will be enabled by default for all users in 57 except for Windows a11y users. At some point, rel eng will shut off all non-e10s tests.
Priority: -- → P4
(Reporter)

Updated

2 months ago
Summary: Stylo: Re-enable Linux64 e10s-off parallel debug tests → Re-enable Stylo Linux64 e10s-off parallel debug tests
Whiteboard: [Stylo]
(In reply to Chris Peterson [:cpeterson] from comment #1)
> We may be able to WONTFIX this bug because e10s will be enabled by default
> for all users in 57 except for Windows a11y users. At some point, rel eng
> will shut off all non-e10s tests.

No, we probably cannot.

It seems to me that the failing tests are all chrome mochitests, which we only run with non-e10s.

Actually, it doesn't matter whether it is e10s at all. mochitest-clipboard, which runs on e10s, seems to be affected as well.
Priority: P4 → P1
As a reference: https://treeherder.mozilla.org/#/jobs?repo=try&revision=61678fac04728706796ad51eb0e6049d74d54711&selectedJob=121328924
Ah, this is about the tests... ok...
Priority: P1 → P4
(Reporter)

Updated

14 days ago
Assignee: nobody → jryans
Status: NEW → ASSIGNED
(Reporter)

Updated

14 days ago
Summary: Re-enable Stylo Linux64 e10s-off parallel debug tests → Re-enable Stylo Linux debug tests impacted by Cairo leak
(Reporter)

Comment 5

14 days ago
Ah, this was already handled in bug 1384701.
Assignee: jryans → nobody
Status: ASSIGNED → RESOLVED
Last Resolved: 14 days ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1384701
You need to log in before you can comment on or make changes to this bug.