Firefox menus don't want to open on Linux in some window managers

RESOLVED FIXED in Firefox 56

Status

()

Firefox
Menus
P1
normal
RESOLVED FIXED
28 days ago
7 days ago

People

(Reporter: catlee, Unassigned)

Tracking

(Blocks: 1 bug, {regression})

Trunk
Firefox 56
x86_64
Linux
regression
Points:
---
Bug Flags:
qe-verify -

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox54 unaffected, firefox55 unaffected, firefox56blocking fixed)

Details

(Whiteboard: [reserve-photon-animation])

(Reporter)

Description

28 days ago
Clicking on the Hamburger menu icon today does nothing. Neither does clicking on the 'Show your bookmarks' button, or the Containers button.
(Reporter)

Comment 1

28 days ago
Sometimes clicking on it changes the mouse cursor to a spinning icon.
(Reporter)

Comment 2

27 days ago
I think I narrowed this down to https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=43a99fa7cf0291c08a2d2baca422161d8d8ab27f&tochange=4e1a1565e4175024b713b04bf20cef1fe34b4cb2
Flags: needinfo?(jaws)
Flags: needinfo?(dao+bmo)
(Reporter)

Comment 3

27 days ago
I'm using i3 as my window manager
What is i3? Is it both matured and actively maintained? Is it popular enough to disable arrow panel animations on Linux again?
Flags: needinfo?(dao+bmo)
Same issue with awesome (matured and maintained)
status-firefox56: --- → affected
tracking-firefox56: --- → blocking
(Reporter)

Comment 6

27 days ago
https://i3wm.org/

It's pretty actively maintained. There were several releases last year, last one in November.

What feature is missing from i3 that would make the arrow panel animations work?
(Reporter)

Comment 7

27 days ago
Both awesome and i3 are tiling window managers, if that matters.
I am affected and I use awesomewm, which (like i3), is a tiling window manager. awesomewm, like i3, is "mature" and actively maintained (last release 8 days ago, i3 is 8 months old).

Is there anything we can help you with?
Maybe this is something about gaining/losing window focus?


(FYI, I also get this for various menus, that catlee didn't mention, like Downloads and Pocket)
status-firefox54: --- → unaffected
status-firefox55: --- → unaffected
status-firefox-esr52: --- → unaffected
Keywords: regression

Comment 9

27 days ago
Had the bug originally in i3 as well. Tried running KDE/Plasma 5.8.7 and it worked fine until I disabled compositing.
Then the same issues appeared. Running i3 with a compositor like compton resolved the issues.
The problem seems to be compositor related.
Blocks: 1007283
Another awesomewm user here with the same problem.  I see freddyb's problems with Downloads and Pocket; the Gecko Profiler addon is also affected.

Updated

27 days ago
Flags: qe-verify?
Whiteboard: [photon-animation] [triage]
Can we backout the patch which caused the Regression? This is making Firefox unusable.
Closing unrequired needinfo for jaws, as we found the culprit.
It was backed out and is fixed for me in latest Nightly. Further work will happen in original bug, which is bug 1007283.

@Dão: Happy to help you debug & test this with a build from try, when we're both in the office, if that helps.
Status: NEW → RESOLVED
Last Resolved: 26 days ago
Flags: needinfo?(jaws)
Resolution: --- → FIXED
status-firefox56: affected → fixed
Target Milestone: --- → Firefox 56
https://hg.mozilla.org/mozilla-central/rev/e91b2c85aacd
Duplicate of this bug: 1385331
Duplicate of this bug: 1385526
Duplicate of this bug: 1385068
Summary: Hamburger menu doesn't work since 2017-07-27 → Firefox menus don't want to open on Linux in some window managers
Duplicate of this bug: 1385557
(Reporter)

Comment 18

26 days ago
Thanks, works now on 2017-07-29's nightly.

Updated

26 days ago
Iteration: --- → 56.4 - Aug 1
Priority: -- → P1
Whiteboard: [photon-animation] [triage] → [reserve-photon-animation]
Flags: qe-verify? → qe-verify-
You need to log in before you can comment on or make changes to this bug.