Sync big data takes hours with using high memory and one core

RESOLVED DUPLICATE of bug 1339390

Status

()

Firefox
Sync
RESOLVED DUPLICATE of bug 1339390
4 months ago
4 months ago

People

(Reporter: BesTo, Unassigned)

Tracking

56 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 months ago
On my machine (Win7, 64-bit), sync big data (thousand of bookmarks and history) takes hours with using high memory and one core.

Guess it shouldn't take hours and never finfish...

What kind of more data can I give for analyze?

Can someone try to sync big data to a new profile and verify my problem?

Comment 1

4 months ago
How many bookmarks? Up to ~10k bookmarks it should work, but it also depends on how the bookmarks are structured - bug 1339390 is the most likely cause. To be sure, can you please follow the instructions at https://wiki.mozilla.org/CloudServices/Sync/File_a_desktop_bug and enable "success" logs, then attempt the sync again and upload any logs?
Flags: needinfo?(Tobias.Besemer)
(Reporter)

Comment 2

4 months ago
I'm sync from Central to Aurora.
https://www.dropbox.com/s/gj14a0tu6avxd3d/logs_central.zip?dl=0
https://www.dropbox.com/s/sfchay5hym0n8nr/logs_aurora.zip?dl=0
Flags: needinfo?(Tobias.Besemer)
Flags: needinfo?(markh)

Comment 3

4 months ago
This is showing at least 19k bookmarks, which is pushing the limits of what we can handle (and note the 95th percentile of bookmark counts for users is just 1.5k, and only 0.75% of users have > 8k). However, each of the logs show Firefox being shutdown during the sync - if you wait long enough, you may find it succeeds, or may find we then strike bug 1339390. I'm really not sure how actionable this is though - there's always going to be some limit where we struggle.
Flags: needinfo?(markh)
(Reporter)

Comment 4

4 months ago
But why is it so slow and needs hours (with high resources)?

After some minutes it use high resources and when the browser gets unresponsible (after a long time), I shut him down...
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1339390
You need to log in before you can comment on or make changes to this bug.