[UX] Menubar - back button from submenu is too small

RESOLVED WONTFIX

Status

()

Firefox
Menus
P5
minor
RESOLVED WONTFIX
6 months ago
2 months ago

People

(Reporter: pe44, Unassigned)

Tracking

({ux-efficiency})

Trunk
ux-efficiency
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 months ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0
Build ID: 20170730100307

Steps to reproduce:

Open the menubar
go to any submenu, e.g. "library"
try to go back to the main menu from there


Actual results:

Instead of being able click the whole upper part, only a very small area around the back arrow was clickable.


Expected results:

In my opinion this counter-intuitive and harder to use than being able to click anywhere on the top of the section, especially since it's visually distinct by a box. Also all other options in the menu are clickable on their full width.

Updated

6 months ago
Component: Untriaged → Menus

Updated

6 months ago
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: ux-efficiency
Bryan, what are your thoughts here?
Flags: needinfo?(bbell)
Priority: -- → P5
Flags: needinfo?(abenson)
Whiteboard: [photon-structure][triage]

Comment 2

3 months ago
It wouldn't be intuitive, or make sense, to make the title of a sub-panel navigate backwards. The back arrow represents a clear affordance for navigation and the click-target is the same as toolbar icons, which are appropriate sizes for menu buttons. The back arrow even includes a hover state to make it clear where to click and that it represents an action. 

I'm inclined to mark this as a wontfix.
Flags: needinfo?(bbell)
Flags: needinfo?(abenson)
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → WONTFIX
Whiteboard: [photon-structure][triage]
Duplicate of this bug: 1417008
You need to log in before you can comment on or make changes to this bug.