30.18% Strings PerfStripCharsWhitespace (linux32-nightly) regression on push 116c714b341eecf34d466907930ad2629f7d9b6a (Wed Jul 26 2017)

RESOLVED INVALID

Status

()

defect
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: igoldan, Unassigned)

Tracking

({perf, regression})

Firefox Tracking Flags

(Not tracked)

Details

We have detected a platform microbenchmarks regression from push:

https://hg.mozilla.org/releases/mozilla-beta/pushloghtml?changeset=116c714b341eecf34d466907930ad2629f7d9b6a

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

 30%  Strings PerfStripCharsWhitespace linux32-nightly opt      1,029,160.83 -> 1,339,735.83

Improvements:

 25%  Strings PerfStripCharsWhitespace linux32-devedition opt      1,332,468.00 -> 995,651.33


You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=8442

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://developer.mozilla.org/en-US/docs/Mozilla/Performance/Automated_Performance_Testing_and_Sheriffing/Platform_Microbenchmarks
::dao I see you are the owner of bug 1367630. Can you look over this regression?
Flags: needinfo?(dao+bmo)
There's no way bug 1367630 can cause this regression.  This test is testing low-level string behavior in gtest.  Bug 1367630 changes the Firefox UI.  The Firefore UI is not even running during this test.

So if there's a regression here, its being blamed on the wrong push.
Flags: needinfo?(dao+bmo) → needinfo?(ionut.goldan)
Looking at the numbers there, it almost looks like something mixed up the nightly and devedition numbers to me...
Component: Untriaged → Tabbed Browser
Again, there is no way a "tabbed browser" change could affect this test.
Component: Tabbed Browser → Untriaged
:bz Thanks for your insights. Will close this as INVALID, due to unreliability of the test on Linux platforms.
Flags: needinfo?(ionut.goldan)
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → INVALID
No longer blocks: 1367630
You need to log in before you can comment on or make changes to this bug.