SVG mask is broken on scroll

RESOLVED DUPLICATE of bug 1318266

Status

()

Core
SVG
P3
normal
RESOLVED DUPLICATE of bug 1318266
4 months ago
3 months ago

People

(Reporter: gl, Assigned: cjku)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 months ago
This a bug report we received from the Stripe team.

STR: 
1. Go to https://stripe.com/atlas
2. Scroll all the way bottom of the page and then back up to "Startup Toolkit" section where the image of the laptop is broken. See screenshot. 

This appears to be a bug with SVG mask.
(Reporter)

Comment 1

4 months ago
Created attachment 8892032 [details]
Screenshot - Mask Issue (Unwanted Lines)
(Reporter)

Comment 2

4 months ago
Created attachment 8892034 [details]
Screenshot - How it should look
(Reporter)

Updated

4 months ago
Attachment #8892032 - Attachment description: Screenshot → Screenshot - Mask Issue
(Reporter)

Updated

4 months ago
Attachment #8892032 - Attachment description: Screenshot - Mask Issue → Screenshot - Mask Issue (Unwanted Lines)
(Reporter)

Comment 3

4 months ago
Another similar issue appears on:
https://stripe.com/us/payments
Scroll to the bottom and back up see the images at the top are broken in a similar way.

Updated

4 months ago
Component: Untriaged → SVG
Please can you create a minimal testcase and add it as an attachment to this bug. An entire complex webpage from a website is simply too much to dig through.
Flags: needinfo?(gl)
Priority: -- → P3
There are 2 regressions here:
#1 Mask function was broken and caused the image was masked out entirely.
Regressed by https://hg.mozilla.org/mozilla-central/rev/619441944e8a

#2 Regression(regression this bug refers to) caused by the fix of #1(bug 1294171) and possibly this patch
https://hg.mozilla.org/mozilla-central/rev/23fcd6d28628

It seems a existing bug and incurred by the fix #1.
Blocks: 1294171
Flags: needinfo?(cku)
(Assignee)

Comment 6

4 months ago
this bug is relative to paint-on-mask layer. I can repro it even by turning of e10s, so it's independant with bug 1382534
Assignee: nobody → cku
No longer blocks: 1294171
Depends on: 1382534
Flags: needinfo?(cku)
(Assignee)

Updated

4 months ago
No longer depends on: 1382534
(Assignee)

Comment 7

4 months ago
And there are both clip-path and mask applied on the computer image
(Reporter)

Updated

4 months ago
Flags: needinfo?(gl)
(Assignee)

Comment 8

3 months ago
Fixed by 
https://hg.mozilla.org/integration/mozilla-inbound/rev/3376bebf1f11#l3.14
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1318266
You need to log in before you can comment on or make changes to this bug.