Closed Bug 1386053 Opened 2 years ago Closed 2 years ago

Enable DevTools tests in Stylo mode for Linux64

Categories

(Core :: CSS Parsing and Computation, enhancement)

enhancement
Not set

Tracking

()

RESOLVED FIXED
mozilla57
Tracking Status
firefox57 --- fixed

People

(Reporter: jryans, Assigned: jryans)

References

Details

(Whiteboard: [Stylo])

Attachments

(2 files)

To avoid regressions in DevTools behavior, let's enable e10s-on parallel only DevTools tests for Stylo on Linux64.
Assignee: nobody → jryans
Status: NEW → ASSIGNED
DevTools tests don't look quite ready to me...

I'm going to enable mochitest except chrome, browser-chrome, a11y, devtools as the first stage of bug 1383992.
(In reply to Xidorn Quan [:xidorn] UTC+10 from comment #1)
> DevTools tests don't look quite ready to me...

Correct, there are still some failures remaining.  I was planning to skip them for now, so we can at least make sure we keep the rest green.
Summary: Stylo: Enable DevTools tests in Stylo mode for Linux64 → Enable DevTools tests in Stylo mode for Linux64
Whiteboard: [Stylo]
Comment on attachment 8893140 [details]
Bug 1386053 - Skip remaining DevTools Stylo failures.

https://reviewboard.mozilla.org/r/164136/#review169494
Attachment #8893140 - Flags: review?(manishearth) → review+
Comment on attachment 8893141 [details]
Bug 1386053 - Enable DevTools tests for Stylo Linux64.

https://reviewboard.mozilla.org/r/164138/#review169496

::: taskcluster/ci/test/test-sets.yml:261
(Diff revision 1)
>      - mochitest-clipboard
>      - mochitest-chrome
>      - xpcshell
> +
> +devtools-tests:
> +    - mochitest-devtools-chrome

Maybe you can more this into `stylo-tests` directly?
Comment on attachment 8893141 [details]
Bug 1386053 - Enable DevTools tests for Stylo Linux64.

https://reviewboard.mozilla.org/r/164138/#review169804

Again, it would be good to have the data in seta before these are enabled but since they only one test suite hopefully the impact won't be as great as when the entire set of stylo suites were enabled.
Comment on attachment 8893141 [details]
Bug 1386053 - Enable DevTools tests for Stylo Linux64.

https://reviewboard.mozilla.org/r/164138/#review169806
Attachment #8893141 - Flags: review?(kmoir) → review+
Comment on attachment 8893141 [details]
Bug 1386053 - Enable DevTools tests for Stylo Linux64.

https://reviewboard.mozilla.org/r/164138/#review169496

> Maybe you can more this into `stylo-tests` directly?

I've only been planning to run DevTools with Stylo on Linux64, whereas `stylo-tests` is being used on multiple platforms.  I could still put this in `stylo-tests` and disable the other platforms via `run-on-projects`, but that feels a bit more cryptic to me.
Pushed by jryans@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/7d9e2aa06502
Skip remaining DevTools Stylo failures. r=manishearth
https://hg.mozilla.org/integration/autoland/rev/a3f35ca41cce
Enable DevTools tests for Stylo Linux64. r=kmoir
https://hg.mozilla.org/mozilla-central/rev/7d9e2aa06502
https://hg.mozilla.org/mozilla-central/rev/a3f35ca41cce
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
You need to log in before you can comment on or make changes to this bug.