--with-system-libevent causes build error on webrtc

RESOLVED FIXED in Firefox 56

Status

()

defect
P2
normal
Rank:
25
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: m_kato, Assigned: m_kato)

Tracking

Trunk
mozilla57
Unspecified
Linux
Points:
---

Firefox Tracking Flags

(firefox56 fixed, firefox57 fixed)

Details

Attachments

(2 attachments)

Whe using --with-system-libevent, ./mach configure throws the following error.


 0:06.39 ==============================
 0:06.39 ERROR PROCESSING MOZBUILD FILE
 0:06.39 ==============================
 0:06.39
 0:06.39 The error occurred while processing the following file or one of the files it includes:
 0:06.39
 0:06.39     /mozilla/mozilla-central/media/webrtc/trunk/gtest/moz.build
 0:06.39
 0:06.39 The error occurred when validating the result of the execution. The reported error is:
 0:06.39
 0:06.39     USE_LIBS contains "libevent", which does not match any LIBRARY_NAME in the tree.
 0:06.39
 0:06.39

Maybe, this is from landing bug 1341285.
Rank: 25
Priority: -- → P2
Attachment #8893210 - Flags: review?(rjesup)
Attachment #8893211 - Flags: review?(rjesup)
Comment on attachment 8893211 [details]
Bug 1386164 - Part 2. Use MOZ_SYSTEM_LIBEVENT for webrtc.

https://reviewboard.mozilla.org/r/164248/#review170054
Attachment #8893211 - Flags: review?(rjesup) → review+
Comment on attachment 8893210 [details]
Bug 1386164 - Part 1. Use libevent2 headers instead of deprecated event.h.

https://reviewboard.mozilla.org/r/164246/#review170056
Attachment #8893210 - Flags: review?(rjesup) → review+
Pushed by m_kato@ga2.so-net.ne.jp:
https://hg.mozilla.org/integration/autoland/rev/8ed89673594e
Part 1. Use libevent2 headers instead of deprecated event.h. r=jesup
https://hg.mozilla.org/integration/autoland/rev/e1ab8bf0905d
Part 2. Use MOZ_SYSTEM_LIBEVENT for webrtc. r=jesup
https://hg.mozilla.org/mozilla-central/rev/8ed89673594e
https://hg.mozilla.org/mozilla-central/rev/e1ab8bf0905d
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
Please uplift to beta.
Flags: needinfo?(m_kato)
Duplicate of this bug: 1372546
Comment on attachment 8893210 [details]
Bug 1386164 - Part 1. Use libevent2 headers instead of deprecated event.h.

Approval Request Comment
[Feature/Bug causing the regression]:
bug 1341285

[User impact if declined]:
User cannot build Firefox with --with-system-libevent.  This option seems to be used on debian (https://bugzilla.mozilla.org/show_bug.cgi?id=1372546#c14)

[Is this code covered by automated tests?]:
No, but this is build only issue with specific build flags that we don't use.

[Has the fix been verified in Nightly?]:
Yes.

[Needs manual test from QE? If yes, steps to reproduce]: 
No, this is build issue.

[List of other uplifts needed for the feature/fix]:
No.

[Is the change risky?]:
No

[Why is the change risky/not risky?]:
This is build issue.

[String changes made/needed]:
No
Flags: needinfo?(m_kato)
Attachment #8893210 - Flags: approval-mozilla-beta?
Attachment #8893211 - Flags: approval-mozilla-beta?
Comment on attachment 8893210 [details]
Bug 1386164 - Part 1. Use libevent2 headers instead of deprecated event.h.

Let's get builds working, please uplift to beta.
Attachment #8893210 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #8893211 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Assignee: nobody → m_kato
You need to log in before you can comment on or make changes to this bug.