Composer adds blank lines to source code

VERIFIED DUPLICATE of bug 46227

Status

SeaMonkey
Composer
--
major
VERIFIED DUPLICATE of bug 46227
16 years ago
13 years ago

People

(Reporter: Chris Weber, Unassigned)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0rc1) Gecko/20020416
BuildID:    Build 200241617

Composer adds blank lines to source code when edited pages (in source code) are
switched from source code mode to normal mode then back to source code mode.

The blank lines added seem to increase as one continues to hack the source code
then switches to normal mode to see how it renders, then back to source code to
see if mozilla screwed it up or not.



Reproducible: Always
Steps to Reproduce:
1. open composer
2. add a table in normal mode and add text to it's cells (i.e. "test")
3. switch to source code mode and edit the cells' text to something else (i.e.
"testing")
4. switch to normal mode then back to source code mode.  The added lines should
appear.

For evidence of the incremental (expodential?) increases of blank lines :

5. While in source code mode edit the title of the page (i.e. <title>This is a
test page</title>)
6. Switch to normal and back to source code.  Observe the many lines of source
code that was added.



Actual Results:  extra blank lines are added to various points in the source code.

Expected Results:  Especially when Mozilla's ability to reformat the source code
is disabled, one expects source code to be unaltered when switch between the
different views of composer.

After editing some of past documents (stubbornly dismissing this bug) I often
find that I must delete 10's of lines of blank code with a text editor to bring
my code back to the way I want it.  This kind of source code manipulation is
what made the old composer of NS 4.0 so un-useable.

After some preliminary research it appears that this is a parsing problem and
has to do with pretty print and the way it was coded.  Please enable the ability
to turn pretty print off.

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 46227 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
verified.
Status: RESOLVED → VERIFIED

Comment 3

15 years ago
reassign in case bugs are later reopened
Assignee: syd → composer
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.