Photon URL alignment has broken containers indicator

RESOLVED DUPLICATE of bug 1378560

Status

()

defect
RESOLVED DUPLICATE of bug 1378560
2 years ago
2 years ago

People

(Reporter: jkt, Unassigned)

Tracking

(Blocks 1 bug, {regression})

Trunk
x86_64
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

Reporter

Description

2 years ago
Posted image Selection_751.png
In Central as of today, the containers indicator has been changed such that it overlaps with then URL bar.
Whiteboard: [photon-structure] [triage]
I'll take a guess that this was caused by bug 1374477.
Blocks: 1374477
No longer blocks: photon-structure
See Also: → 1378560
TBH, I suspect it's not worth fixing this separately from bug 1378560.
(In reply to Johann Hofmann [:johannh] from comment #1)
> I'll take a guess that this was caused by bug 1374477.

Confirmed via mozregression. (I hit this bug as well, and was motivated to track it down & file a bug; happy to find it's already been filed.)

https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=807acedaf25de607e78ef55453cef1a5e25e183c&tochange=280149adf2844c7f04f92e67f6beaae3d27e3693


STR:
 1. Install Test Pilot and Containers experiment from https://testpilot.firefox.com/
 2. Long-click the new tab icon, in tabstrip (click and hold)
 3. From the 'containers' menu that appears, choose 'work'.

ACTUAL RESULTS:
The briefcase "work" icon is directly adjacent to the edge of the URL bar.

EXPECTED RESULTS:
The URL bar should have some padding at its right edge (and the containers icon should probably be to the left of the page-action menu? That's how it was before this regressed)

Side note: The original screenshot here used "Banking" as the container-category, and that looks similarly-broken in my main profile, but it's less-obviously-broken in a fresh profile because the dollar-sign icon is skinnier there -- it doesn't get a circle background for some reason. Maybe there's been a Containers icon refresh that only takes effect for new installs? not sure. In any case, "Work" has a reliably wide icon (in my main profile & in a fresh profile), & hence that one is a good way to reliably see the brokenness here.
Keywords: regression
Going to dupe this over to the bug where this'll get fixed: bug 1378560.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1378560
Whiteboard: [photon-structure] [triage]
See Also: 1378560
You need to log in before you can comment on or make changes to this bug.