Closed Bug 1386935 Opened 2 years ago Closed 2 years ago

Stylo: massive memory use on video.bing.com

Categories

(Core :: CSS Parsing and Computation, defect)

57 Branch
x86_64
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1384945

People

(Reporter: alanhdu, Unassigned)

References

(Blocks 2 open bugs, )

Details

(Keywords: memory-footprint, nightly-community)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20170802100302

Steps to reproduce:

1. Open a new Firefox session
2. Go to `about:config` and enable `layout.css.servo.enabled`
3. Go to https://video.bing.com


Actual results:

The Firefox web content process suddenly used >1.5 GB of RAM.

Even worse, **each** tab with video.bing.com on it seems to eat up >1.5 GB, so I accidentally OOM-ed myself when I tried to watch 4 different videos.

The about:memory page reports:
1,640.76 MB (100.0%) -- explicit
├──1,513.14 MB (92.22%) ── heap-unclassified
├─────40.28 MB (02.46%) -- js-non-window
│     ├──23.61 MB (01.44%) -- zones
│     │  ├──21.90 MB (01.33%) ++ zone(0x7f49b2afc000)
│     │  └───1.71 MB (00.10%) ++ (2 tiny)
│     └──16.67 MB (01.02%) ++ (2 tiny)
├─────34.17 MB (02.08%) -- heap-overhead
│     ├──32.06 MB (01.95%) ── bookkeeping
│     └───2.11 MB (00.13%) ++ (2 tiny)
├─────24.66 MB (01.50%) ++ window-objects/top(http://www.bing.com/videos/explore?FORM=RECMVI, id=6442450945)
├─────17.31 MB (01.06%) -- images/content
│     ├──16.99 MB (01.04%) ++ raster
│     └───0.32 MB (00.02%) ++ vector/used
└─────11.19 MB (00.68%) ++ (18 tiny)


Expected results:

If I don't enable `layout.css.servo.enabled`, then video.bing.com "only" uses ~600 MB of RAM -- still a lot, but much more reasonable than 1.5 GB (especially because it seems that opening multiple video.bing.com tabs here does not allocate another 600 MB per tab).

Without `layout.css.servo.enabled`, about:memory reports:

604.35 MB (100.0%) -- explicit
├──423.18 MB (70.02%) -- layout
│  ├──422.81 MB (69.96%) ── rule-processor-cache
│  └────0.37 MB (00.06%) ── style-sheet-cache
├───53.06 MB (08.78%) ── heap-unclassified
├───46.80 MB (07.74%) -- js-non-window
│   ├──34.91 MB (05.78%) -- zones
│   │  ├──18.13 MB (03.00%) ++ zone(0x7f98783ea000)
│   │  ├──15.38 MB (02.54%) -- zone(0x7f98682a9000)
│   │  │  ├───9.81 MB (01.62%) -- shapes
│   │  │  │   ├──7.22 MB (01.19%) ++ gc-heap
│   │  │  │   └──2.59 MB (00.43%) ++ malloc-heap
│   │  │  └───5.57 MB (00.92%) ++ (14 tiny)
│   │  └───1.40 MB (00.23%) ++ (2 tiny)
│   ├───9.28 MB (01.54%) ++ runtime
│   └───2.61 MB (00.43%) ++ gc-heap
├───46.67 MB (07.72%) -- window-objects
│   ├──37.38 MB (06.19%) -- top(http://www.bing.com/videos/explore?FORM=RECMVI, id=2147483649)/active
│   │  ├──30.95 MB (05.12%) ++ (34 tiny)
│   │  └───6.43 MB (01.06%) ++ window(http://www.bing.com/videos/explore?FORM=RECMVI)
│   └───9.29 MB (01.54%) ++ top(none)/detached/window([system])
├───18.88 MB (03.12%) -- images
│   ├──17.32 MB (02.87%) -- content
│   │  ├──17.00 MB (02.81%) -- raster
│   │  │  ├──16.71 MB (02.76%) ++ used
│   │  │  └───0.29 MB (00.05%) ++ unused/image(366x204, data:image/jpeg;base64,/9j/4AAQSkZJRgABAQEAYABgAAD/2wBDABwTFRgVERwYFhgfHRwhKUUtKSYmKVQ8QDJFZFhpZ2JYYF9ufJ6GbnWWd19gir
uLlqOpsbOxa4TC0MGszp6usar/2wBDAR0fHykkKVEtLVGqcmByqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqr/wAARCADMAW4DASIAAhEBA (truncated))
│   │  └───0.32 MB (00.05%) ++ vector/used
│   └───1.56 MB (00.26%) ++ uncached/raster/used/image(1250x300, http://tse4.mm.bing.net/th?id=OSC.TOOL06D6DC15A1B55CBE9E8D9326F086FF1BBC371127BC87CDFA0AD6220C7CCFCC09&pid=1
.12&eid=G.TOOL06D6DC15A1B55CBE9E8D9326F086FF1BBC371127BC87CDFA0AD6220C7CCFCC09)
├────8.53 MB (01.41%) ++ heap-overhead
└────7.22 MB (01.20%) ++ (17 tiny)
Component: Untriaged → CSS Parsing and Computation
Keywords: footprint
Product: Firefox → Core
Thanks for keeping an eye on it! :)
But I can't reproduce this. Maybe someone else has an idea.

Should this block stylo-site-issues, bug 1293767 or both?
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Summary: Stylo causes massive memory use on video.bing.com → Stylo: massive memory use on video.bing.com
Hi, thanks for the report!

Do you have any add-ons installed? If so, which ones?

Thanks!
Blocks: stylo-memory
Huh... how strange. When I updated to the 2017-08-03 nightly this morning, I can no longer reproduce this. Sorry for the noise!

But for the record, I only have VimFx and Addblock Plus installed.
(In reply to alanhdu from comment #3)
> [...] I can no longer reproduce this. [...]
> But for the record, I only have [...] Adblock Plus installed.

Then I would mark this as a duplicate of bug 1384945.
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1384945
You need to log in before you can comment on or make changes to this bug.