[Form Autofill] Collect information on how many people enable credit card Autofill

RESOLVED FIXED in Firefox 56

Status

()

defect
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: steveck, Assigned: steveck)

Tracking

(Blocks 1 bug)

unspecified
mozilla57
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox55 unaffected, firefox56 fixed, firefox57 fixed)

Details

(Whiteboard: [story][form autofill:M4][autofill-metrics])

Attachments

(2 attachments)

Assignee

Description

2 years ago
Similar to bug 990199, but it's another probe for recording credit card enable preference.
Comment hidden (mozreview-request)
Assignee

Comment 3

2 years ago
Hi francois, this patch is mainly for recording the enable pref flag of credit card autofill feature. It's commented because it's not ready yet, but it'll be in FF 56 eventually since it's a system addon and it could be uplifted easily even after code freeze. The problem is adding code in central like TelemetryEnvironment.jsm is not as flexible as system addon, so that's why we want to land the probe before 56 code freeze. Please let me know it you think it's inappropriate, thanks.

Comment 4

2 years ago
mozreview-review
Comment on attachment 8893326 [details]
Bug 1387004 - Part 2: Record credit card enable state in TelemetryEnvironment.

https://reviewboard.mozilla.org/r/164404/#review170048

This is Category 2 data (https://wiki.mozilla.org/Firefox/Data_Collection#Data_Collection_Categories). datareview+.
Attachment #8893326 - Flags: review?(francois) → review+

Comment 5

2 years ago
mozreview-review
Comment on attachment 8893325 [details]
Bug 1387004 - Part 1: Add credit card enabled pref.

https://reviewboard.mozilla.org/r/164400/#review170136
Attachment #8893325 - Flags: review?(lchang) → review+
Assignee

Updated

2 years ago
Keywords: checkin-needed
Assignee

Comment 6

2 years ago
Comment on attachment 8893325 [details]
Bug 1387004 - Part 1: Add credit card enabled pref.

Approval Request Comment
[Feature/Bug causing the regression]: Not a regression, see comment 3 for more details.
[User impact if declined]: No impact
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: N/A
[Needs manual test from QE? If yes, steps to reproduce]: N/A
[List of other uplifts needed for the feature/fix]: N/A
[Is the change risky?]: No
[Why is the change risky/not risky?]: It only add a pref
[String changes made/needed]: No
Attachment #8893325 - Flags: approval-mozilla-beta?
Assignee

Comment 7

2 years ago
Comment on attachment 8893326 [details]
Bug 1387004 - Part 2: Record credit card enable state in TelemetryEnvironment.

Approval Request Comment
[Feature/Bug causing the regression]: Not a regression, see comment 3 for more details.
[User impact if declined]: No impact
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: N/A
[Needs manual test from QE? If yes, steps to reproduce]: N/A
[List of other uplifts needed for the feature/fix]: N/A
[Is the change risky?]: No
[Why is the change risky/not risky?]: It only add a telemetryEnvironment probe
[String changes made/needed]: No
Attachment #8893326 - Flags: approval-mozilla-beta?

Comment 8

2 years ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/cfca1dca3023
Part 1: Add credit card enabled pref. r=lchang
https://hg.mozilla.org/integration/autoland/rev/c634cf8e1306
Part 2: Record credit card enable state in TelemetryEnvironment. r=francois
Keywords: checkin-needed
Comment on attachment 8893325 [details]
Bug 1387004 - Part 1: Add credit card enabled pref.

Let's uplift this for 56 beta 1, looks like it just adds a pref, and it's had data review.
Attachment #8893325 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #8893326 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.