Closed Bug 1387490 Opened 2 years ago Closed 2 years ago

stylo: _cairo_hash_table_destroy: Assertion `hash_table->live_entries == 0' failed

Categories

(Core :: Graphics, defect, P2)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1384701
Tracking Status
firefox-esr52 --- unaffected
firefox55 --- unaffected
firefox56 --- wontfix
firefox57 --- affected

People

(Reporter: jkratzer, Assigned: karlt)

References

(Blocks 2 open bugs)

Details

(Keywords: assertion, testcase)

Attachments

(1 file)

Attached file trigger.html
Attached testcase causes an assertion in m-c rev 36ad88e6b7b2 with stylo enabled by pref.

firefox: ../../../../src/cairo-hash.c:217: _cairo_hash_table_destroy: Assertion `hash_table->live_entries == 0' failed.

Exit code: -6
Flags: in-testsuite?
This looks like bug 1384701, but potentially does not require disabling e10s. Jason, can you confirm this was with e10s enabled?
Flags: needinfo?(jkratzer)
(In reply to Bobby Holley (:bholley) (busy with Stylo) from comment #1)
> This looks like bug 1384701, but potentially does not require disabling
> e10s. Jason, can you confirm this was with e10s enabled?

This was identified with e10s disabled.
Flags: needinfo?(jkratzer)
Still good to have a fairly minimal testcase for this issue at least.

I have also noticed the e10s enabled variant happen in some DevTools test runs (mentioned in bug 1384701 comment 7).
See Also: → 1384701
Priority: -- → P2
Blocks: 1384701
Summary: stylo: Assertion `hash_table->live_entries == 0' failed → stylo: _cairo_hash_table_destroy: Assertion `hash_table->live_entries == 0' failed
Karl is looking at this over in bug 1384701. Do I understand that this is the same bug, and just a testcase for it? Should we merge them?
Assignee: nobody → karlt
Flags: needinfo?(jryans)
(In reply to Bobby Holley (:bholley) (busy with Stylo) from comment #4)
> Karl is looking at this over in bug 1384701. Do I understand that this is
> the same bug, and just a testcase for it? Should we merge them?

Right, this is the same issue.  I'll mark this as a duplicate and mention it in the other bug.
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(jryans)
Resolution: --- → DUPLICATE
See Also: 1384701
Duplicate of bug: 1384701
You need to log in before you can comment on or make changes to this bug.