Closed Bug 1387609 Opened 3 years ago Closed 2 years ago

"Close tab" button icon in the tab bar are too dark after landing patch from bug #1385702

Categories

(Firefox :: Theme, defect, P1)

57 Branch
x86_64
Windows 7
defect

Tracking

()

VERIFIED FIXED
Firefox 58
Tracking Status
firefox-esr52 --- unaffected
firefox55 --- unaffected
firefox56 --- unaffected
firefox57 --- verified
firefox58 --- verified

People

(Reporter: Virtual, Assigned: dao)

References

Details

(Keywords: nightly-community, ux-consistency, Whiteboard: [reserve-photon-visual][p4])

Attachments

(1 file)

Has Regression Range: --- → yes
Has STR: --- → irrelevant
What button is this bug talking about?
This bug is about "close tab" button, as stated in this bug summary.



(In reply to Virtual_ManPL [:Virtual] - (please needinfo? me - so I will see your comment/reply/question/etc.) from comment #0)
> Probably caused by:
> Bug #1372689 - Update tab strip button icons

It should be:
Probably caused by:
Bug 1385702 - Update close icon style for photon
This should be the same fix as bug 1384686.
Tabbar icons should use var(--toolbarbutton-icon-fill) like navigation bar icons.
> This bug is about "close tab" button, as stated in this bug summary.

The summary mentions the location bar, which doesn't seem to make any sense.

Tab close buttons use the same color as tab labels, as specified here: http://design.firefox.com/people/shorlander/photon/Mockups/windows-10.html

The default text color is however lighter than what Windows uses by default.
(In reply to Tim Nguyen :ntim from comment #4)
> Tabbar icons should use var(--toolbarbutton-icon-fill) like navigation bar
> icons.

No, they shouldn't.
(In reply to Dão Gottwald [::dao] from comment #5)
> > This bug is about "close tab" button, as stated in this bug summary.
> 
> The summary mentions the location bar, which doesn't seem to make any sense.

Valid point. Fixing summary.
Summary: "Close tab" button icon in the location bar are too dark after landing patch from bug #1385702 → "Close tab" button icon in the tab bar are too dark after landing patch from bug #1385702
Whiteboard: [photon-visual] [triage] → [reserve-photon-visual][p4]
Flags: qe-verify?
Priority: -- → P3
Priority: P3 → P4
Flags: qe-verify? → qe-verify+
No longer blocks: photon-visual
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Priority: P4 → P1
Comment on attachment 8910732 [details]
Bug 1387609 - Use --toolbarbutton-icon-fill-opacity for the tab close button.

https://reviewboard.mozilla.org/r/182188/#review187868
Attachment #8910732 - Flags: review?(nhnt11) → review+
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6a0e5139dc99
Use --toolbarbutton-icon-fill-opacity for the tab close button. r=nhnt11
Note for future:

I was a little confused why we were using stroke-opacity for the fill-opacity, but Dão clarified on IRC that it's because we're already using context-fill-opacity for the background behind the X. So as a workaround, we use stroke-opacity to be able to set a different value for the fill-opacity of the X.
https://hg.mozilla.org/mozilla-central/rev/6a0e5139dc99
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
Comment on attachment 8910732 [details]
Bug 1387609 - Use --toolbarbutton-icon-fill-opacity for the tab close button.

Approval Request Comment
[Feature/Bug causing the regression]: photon-visual polish
[User impact if declined]: tab close button icon color is inconsistent with other toolbar buttons
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: not yet
[Needs manual test from QE? If yes, steps to reproduce]:
[List of other uplifts needed for the feature/fix]:
[Is the change risky?]: no
[Why is the change risky/not risky?]: trivial fix
[String changes made/needed]:
Attachment #8910732 - Flags: approval-mozilla-beta?
I'm confirming that bug is fixed, starting in Mozilla Firefox Nightly 58.0a1 (2017-09-23), so I'm marking this bug as VERIFIED.
Thank you very much! \o/
Status: RESOLVED → VERIFIED
Comment on attachment 8910732 [details]
Bug 1387609 - Use --toolbarbutton-icon-fill-opacity for the tab close button.


Polish photon, taking it
should be in 57b3
Attachment #8910732 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.