Closed Bug 1387614 Opened 3 years ago Closed 3 years ago

Padlock icon is too small and should be bigger

Categories

(Firefox :: Theme, defect, P1)

57 Branch
x86_64
Windows 7
defect

Tracking

()

VERIFIED FIXED
Firefox 57
Iteration:
57.1 - Aug 15
Tracking Status
firefox57 --- verified

People

(Reporter: Virtual, Assigned: daleharvey)

References

(Blocks 1 open bug)

Details

(Keywords: nightly-community, ux-consistency, Whiteboard: [reserve-photon-visual][p3])

Attachments

(6 files)

Padlock icon is too small and should be bigger
to meet specification - http://design.firefox.com/photon/visual/color.html#themes

Because for now:
14 x 14 px - "i" information icon size
10 x 12 px - padlock icon size
Has Regression Range: --- → irrelevant
Has STR: --- → irrelevant
QA Contact: Virtual
http://design.firefox.com/people/shorlander/photon/Mockups/images-general/secure-16.svg
Whiteboard: [photon-visual] [triage] → [reserve-photon-visual][p3]
Priority: -- → P3
Yeh forgot we only changed the color and not the icon till the merge
Assignee: nobody → dharvey
Comment on attachment 8896289 [details]
Bug 1387614 - Update secure connection icon for photon.

https://reviewboard.mozilla.org/r/167562/#review172748

::: browser/themes/shared/identity-block/connection-secure.svg:2
(Diff revision 1)
> -<?xml version="1.0" encoding="utf-8"?>
> -<!-- This Source Code Form is subject to the terms of the Mozilla Public
> +<svg xmlns="http://www.w3.org/2000/svg" width="16" height="16" viewBox="0 0 16 16">
> +  <path fill="context-fill" d="M12,7 L13,7 C13.5522847,7 14,7.44771525 14,8 L14,14 C14,14.5522847 13.5522847,15 13,15 L3,15 C2.44771525,15 2,14.5522847 2,14 L2,8 C2,7.44771525 2.44771525,7 3,7 L4,7 L4,5.00032973 C4,2.79202307 5.79321704,1 8,1 C10.2075938,1 12,2.79481161 12,5.00032973 L12,7 Z M10,7 L10,5.00032973 C10,3.89878113 9.10242341,3 8,3 C6.89748845,3 6,3.89689088 6,5.00032973 L6,7 L10,7 Z"/>

Please add back the license header.
Comment on attachment 8896289 [details]
Bug 1387614 - Update secure connection icon for photon.

https://reviewboard.mozilla.org/r/167562/#review172756

::: browser/themes/shared/identity-block/connection-secure.svg:1
(Diff revisions 1 - 2)
> +<?xml version="1.0" encoding="utf-8"?>

Please remove <?xml version="1.0" encoding="utf-8"?> again since it's useless ;)
Status: NEW → ASSIGNED
Iteration: --- → 57.1 - Aug 15
Flags: qe-verify?
Priority: P3 → P1
Comment on attachment 8896289 [details]
Bug 1387614 - Update secure connection icon for photon.

https://reviewboard.mozilla.org/r/167562/#review172830
Attachment #8896289 - Flags: review?(dao+bmo) → review+
Pushed by dharvey@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d959eb7903fd
Update secure connection icon for photon. r=dao
https://hg.mozilla.org/mozilla-central/rev/d959eb7903fd
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Thank you very much \o/.

I'm confirming that bug is fixed, starting in Mozilla Firefox 57.0a1 (2017-08-13), so I'm marking this bug as VERIFIED.
Status: RESOLVED → VERIFIED
Flags: qe-verify?
See Also: → 1390511
Depends on: 1390511
See Also: 1390511
You need to log in before you can comment on or make changes to this bug.