If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Feature request: Options for disabling javascripts from hooking mouse buttons and opening alert windows

VERIFIED DUPLICATE of bug 86193

Status

SeaMonkey
Preferences
--
enhancement
VERIFIED DUPLICATE of bug 86193
16 years ago
13 years ago

People

(Reporter: Juha Nieminen, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0rc1) Gecko/20020417
BuildID:    2002041711

This is just a feature request, not a bug report.

It would be really nice if there were options to disable javascripts
from hooking the mouse buttons and opening alert windows (this is
an extremely annoying thing in many pages).


Reproducible: Didn't try
Steps to Reproduce:

Comment 1

16 years ago
When I get you right, You're talking about those scripts which
are proposed to disable viewing Page source?
When adding such a feature, one could also think about a function
which disables pop-up windows when user closes a window/leaves a website.
Opera 6 has a very nice implementation, which lets the user change
such settings very quickly by pressing F12.
dup of bug 86193

Comment 3

16 years ago
Looks so.

*** This bug has been marked as a duplicate of 86193 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
marking verified as a duplicate.

if you decide to reopen this bug, please clarify why.

search string for bugspam removal: SalviaGuaranitica
Status: RESOLVED → VERIFIED

Comment 5

15 years ago
Pref to disable alerts -> bug 185384
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.