Connection error in new tab leaves address bar blank

VERIFIED DUPLICATE of bug 103720

Status

SeaMonkey
Tabbed Browser
VERIFIED DUPLICATE of bug 103720
16 years ago
10 years ago

People

(Reporter: Malcolm Scott, Assigned: jag (Peter Annema))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc1) Gecko/20020417
BuildID:    2002041711

If a tab is opened with a URL (e.g. from middle-click, or Ctrl+Enter, or
dragging a bookmark onto an empty space on the tab bar) and loading of that URL
fails (e.g. due to a DNS lookup error), then the address bar remains blank,
rather than containing the URL specified.

Reproducible: Always
Steps to Reproduce:
1. Set your prefs so that Ctrl+Enter and Middle-click will open in a new tab.
2. Type an invalid URL into the address bar (e.g. http://www.abc.def/ ) or
middle-click that link.
3. The error "www.abc.def could not be found" error appears, as expected, but...

Actual Results:  The address bar for the new tab is blank.

Expected Results:  The address bar should contain the URL specified (in this
case http://www.abc.def/ ).

Why this is bad:
1. If I mistyped a URL, then I want to be able to correct it (e.g. to change
".com" into ".net" or whatever) without retyping it.
2. If my internet connection has gone down, I want to be able to reconnect and
try again.
etc.

This bug is almost certainly related to the fact that, when loading a page in a
new tab, the URL is not displayed in the address bar until data starts arriving.

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 103720 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
marking verified as a duplicate.

if you decide to reopen this bug, please clarify why.

search string for bugspam removal: SalviaGuaranitica
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.